cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Lens is not registering on R6

elizabethgeorge
Apprentice

Hi, I purchased the 35mm last year and it was working correctly. I attached it to my R6 a month ago and my R6 was not recognizing my lens. I reattached it multiple times and it is no longer recognizing it. Do you know what might be wrong? 

3 REPLIES 3

Greetings ,

Sorry to hear your lens is not being detected or working as expected.  If this issue is only occurring with the 35 mm and not other lenses, it should probably be inspected by Canon.

All cameras and lenses come with a one-year warranty.  To receive support, please register your product in the My Cannon portal.  From there you can open a case and receive information on next steps for service.  Canon has service centers on the east and west coasts.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It

Waddizzle
Legend

What brand and model of lens are you using?

Which camera model(s) are able to use the lens successfully?

If the lens uses an EF mount, are you using a Canon branded mount adapter?

--------------------------------------------------------
"The right mouse button is your friend."

Denton667
Apprentice

If this issue is only occurring with the 35 mm and not other lenses, it should probably be inspected by Canon. All cameras and lenses come with a one-year warranty. NCED Cloud To receive support, please register your product in the My Cannon portal. From there you can open a case and receive information on next steps for service.

Avatar
Enter for a chance to win
Announcements