cancel
Showing results for 
Search instead for 
Did you mean: 

EOS 90D and external intervalometer - can't get working

Hedodoc
New Contributor

It's been 30 years since I bought my last camera and things have changed!  I got an EOS 90D to use for astrophotography but for the life of me I cannot get my intervalometer to work correctly.

 

I have things setup to take 1 second exposures every two seconds for a total of 10 shots.  Please note I am NOT using the built in intervalometer but an external one. 

 

If I set the camera to BULB mode, the shutter stays open the entire time for the interval shooting. The shutter never closes until the entire interval is done. So I get essentially a 20-something second exposure.    If I set the camera to manual mode, the camera shutter opens for what-ever time I have the camera set for, ignoring the shutter speed the intervalmoter is set for. 

 

I suspect there is some setting in the camera I have to change but "intervalometer" is not even listed in the manual I have. Yes I have tried to read the manual but it doesn't address an external intervalometer.  

 

What am I doing wroing??

 

.............Bob 

 

 

1 ACCEPTED SOLUTION

Just for completeness and if anyone else has this issue, the intervalmeter I originally got is not compatible with the EOS 90D.  I thought since it worked with the 80D, it would also work with the 90D.  Wrong.

 

I purchased a new one that specifically mentioned the 90D and it works flawlessly.  It's the Aodelan WTR-2.  Nice thing about this unit is it will also work wirelessly with the camera, but through it's own wireless receiver that hooks to the hot shoe and then connects to the camera with a wire.  The main control unit then connects wirelessly with that unit and works fine. 

View solution in original post

9 REPLIES 9

Waddizzle
VIP

Make sure your external switch has been set up correctly.  Note the final comment in the blue box..  Page 120

 

CAAF51A1-F0CA-4543-8EDC-798A93209112.jpeg

 

------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."


@Hedodoc wrote:

It's been 30 years since I bought my last camera and things have changed!  I got an EOS 90D to use for astrophotography but for the life of me I cannot get my intervalometer to work correctly.

 

I have things setup to take 1 second exposures every two seconds for a total of 10 shots.  Please note I am NOT using the built in intervalometer but an external one. 

 

If I set the camera to BULB mode, the shutter stays open the entire time for the interval shooting. The shutter never closes until the entire interval is done. So I get essentially a 20-something second exposure.    If I set the camera to manual mode, the camera shutter opens for what-ever time I have the camera set for, ignoring the shutter speed the intervalmoter is set for. 

 

I suspect there is some setting in the camera I have to change but "intervalometer" is not even listed in the manual I have. Yes I have tried to read the manual but it doesn't address an external intervalometer.  

 

What am I doing wroing??

 

.............Bob 

 

 


Verify that the Bulb Timer setting in the images that Waddizzle posted is set to Disable. All you should need to do is set the camera to Bulb and then press the button on the remote intervalometer.

 

I use one all the time on my 1D X III.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

Thanks for the replies.

 

I have been trying different settings and still cannot get this to work.  If I set the camera in BULB mode, the shutter button on the intervalometer works just fine.  The shutter opens and stays open as long as I hold the button down. Release the button and the shutter closes. No problem.

 

However, when I set the intervalometer up for multiple exposures, say 10 shots at 1 second each with 2 seconds between shots and run the sequence, the shutter correctly opens at the start of the first exposure then STAYS OPEN throughout the sequence and does not close until the sequence completes, so rather than having 10 shots at 1 second each, I have ONE shot at 30 something seconds. 

 

Honestly I am beginning to think the intervalometer I have is not compatible with the EOS 90D.  It's a Photoolex T710.  It's listed as compatible with the EOS 80D but I don't see the 90D listed, but I would think it would work.  I had to dowload a new version of Digital Photo Professional to work with the 90D so some things have changed.

 

I will do some more research on the correct intervalometer as I think it's the problem now.

 

 


@Hedodoc wrote:

Thanks for the replies.

 

I have been trying different settings and still cannot get this to work.  If I set the camera in BULB mode, the shutter button on the intervalometer works just fine.  The shutter opens and stays open as long as I hold the button down. Release the button and the shutter closes. No problem.

 

However, when I set the intervalometer up for multiple exposures, say 10 shots at 1 second each with 2 seconds between shots and run the sequence, the shutter correctly opens at the start of the first exposure then STAYS OPEN throughout the sequence and does not close until the sequence completes, so rather than having 10 shots at 1 second each, I have ONE shot at 30 something seconds. 

 

Honestly I am beginning to think the intervalometer I have is not compatible with the EOS 90D.  It's a Photoolex T710.  It's listed as compatible with the EOS 80D but I don't see the 90D listed, but I would think it would work.  I had to dowload a new version of Digital Photo Professional to work with the 90D so some things have changed.

 

I will do some more research on the correct intervalometer as I think it's the problem now.

 

 


Some intervalometers work by having the shutter time embedded in the interval; others do not.

 

So, if you want a shutter speed of 1 second and a two second gap you would set a shutter speed of 1 second and an interval of 3 seconds (1+2).

 

Screenshot 2021-09-02 140422.jpg

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

To add to what John just posted above, some intervalometer also require a minimum amount of time between shots.  In my expecrience, one second is a common minimum interval between shots.  

 

If you are setting two different time periods, 1 second and 2 seconds, to repeat 10 times, and wind up with a 30 second exposure, then it does not sound like the overlap behavior John describes above.

 

Make sure you are entering the correct time period into the correct setting.  Make sure you are not setting up 2 second exposures that are only 1 second apart.

------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."

Also, disable any and all noise reduction settings, especially Long Exposure Noise Reduction.

------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."


@jrhoffman75 wrote:

@Hedodoc wrote:

Thanks for the replies.

 

I have been trying different settings and still cannot get this to work.  If I set the camera in BULB mode, the shutter button on the intervalometer works just fine.  The shutter opens and stays open as long as I hold the button down. Release the button and the shutter closes. No problem.

 

However, when I set the intervalometer up for multiple exposures, say 10 shots at 1 second each with 2 seconds between shots and run the sequence, the shutter correctly opens at the start of the first exposure then STAYS OPEN throughout the sequence and does not close until the sequence completes, so rather than having 10 shots at 1 second each, I have ONE shot at 30 something seconds. 

 

Honestly I am beginning to think the intervalometer I have is not compatible with the EOS 90D.  It's a Photoolex T710.  It's listed as compatible with the EOS 80D but I don't see the 90D listed, but I would think it would work.  I had to dowload a new version of Digital Photo Professional to work with the 90D so some things have changed.

 

I will do some more research on the correct intervalometer as I think it's the problem now.

 

 


Some intervalometers work by having the shutter time embedded in the interval; others do not.

 

So, if you want a shutter speed of 1 second and a two second gap you would set a shutter speed of 1 second and an interval of 3 seconds (1+2).

 

Screenshot 2021-09-02 140422.jpg


Here's the other type, where the interval is inserted between the closing of the shutter and the next opening.

 

Screenshot 2021-09-02 145706.jpg

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

Just for completeness and if anyone else has this issue, the intervalmeter I originally got is not compatible with the EOS 90D.  I thought since it worked with the 80D, it would also work with the 90D.  Wrong.

 

I purchased a new one that specifically mentioned the 90D and it works flawlessly.  It's the Aodelan WTR-2.  Nice thing about this unit is it will also work wirelessly with the camera, but through it's own wireless receiver that hooks to the hot shoe and then connects to the camera with a wire.  The main control unit then connects wirelessly with that unit and works fine. 

View solution in original post

1stSolo
Occasional Contributor

Yes, you've got to check compatibility.

But I also broke the remote shutter release port 10 years ago on my 70D and my only way of remotely controlling it was by enabling wifi function and using an iphone app (CCC Pro - $12). It turned out to be cheaper than the physical remote and also gives you the flexibility of pushing LiveView onto your iphone/ipad along with subs.

The only downsides are:

1. battery drains faster, so i've been using AC/DC adapter to be able to do astrophotography all night long
2. Existing the app or locking the screen disconnects from the camera, ending the sequence. So I also have iphone plugged into power source and screen locking disabled.