cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 90D & EF 100-400mm - Auto Focus doesn't work with 2x extender

jcampbriar
Apprentice

I have a 90D with an EF 100-400 lens.  When I put on my 2X extender the autofocus doesn't work at all.  Is there some setting I need to change?

11 REPLIES 11

Waddizzle
Legend
Legend

That is normal behavior for that specific combination of camera body, lens, and extender.  Please refer to the”90D Supplemenatl Information” guide for a detailed explanation.

https://gdlp01.c-wss.com/gds/8/0300036248/02/eos90d-si2-en.pdf 

--------------------------------------------------------
"The right mouse button is your friend."

I apoligize for telling you to read the manual.  But this is not a simple topic to discuss.  You need to be able to “speak the language”, if you will.  If you have any questions, just ask.

--------------------------------------------------------
"The right mouse button is your friend."

Peter
Authority
Authority

As a workaround you can enable Live view.


@Peter wrote:

As a workaround you can enable Live view.


I’m just a little surprised the camera does not produce an error message.  The camera/lens combo is not listed to work with any version of the 2.0x.  That’s usual result when you try to use unlisted combinations.

--------------------------------------------------------
"The right mouse button is your friend."

Had success with 6D +100-400 +x2III in Live view.


@Peter wrote:

Had success with 6D +100-400 +x2III in Live view.


Interesting.  I don’t even get that far.  Error message on power up with that body and the 6D2.  

No idea what firmware is in the cameras.  I think the last firmware update I did was the security update for the USB port a couple of years ago, 

--------------------------------------------------------
"The right mouse button is your friend."

In live view, my EOS 80D does DPAF like a mirrorless camera so with enough light it will even autofocus at F/13. I would guess that the EOS 90D does even better.

I find live view awkward for hand held shots with the EOS 80D and did not use it much.

The lens and extender should work fine with auto focus in live view when there is enough light.

Here is an auto focus example using an unsupported combination at F/11 on EOS 80D where auto focus worked: https://www.rsok.com/~jrm/2017Feb07_birds_and_cats/2017feb01_cardinal_IMG_0929.html  

 

---
https://www.rsok.com/~jrm/

jcampbriar
Apprentice

Thanks for the feedback.  At least if wasn't something I was doing.  

elmo
Contributor

I have this issue with my R8 and RF100-500 with the RF2x. I enabled using the manual focus ring in the settings even when in AF. Once I have my subject in focus manually, AF seems to work fine afterwards (like on a moon shot).

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements