cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 80D Error 70

AlexTischer
Contributor

Please, help! How to solve err70 on Canon 80d? It occurs only when the camera is set in video mode. The camera shuts down after about 2 minutes and shows that error. It happens with my Canon 17-55, my Canon 18-55 and my tamron 70-200 g2. No problems with my Tokina 11-16 instead... With 5dmk4 I have no problem at all with every lens.

29 REPLIES 29

"I have the problem with 4 out of a 5 lenses kit. I have had it before and after 1.0.2->1.0.3 update. I have it connecting camera to usb 3.0 pc port as well as if I connect it to usb 2.0 pc port"

 

OK now you know what it is not!  Did you rule out overheating?  If that is, not overheating, then you need to send it in for Canon service.

EB
EOS 1DX and 1D Mk IV and several lenses!


@AlexTischer wrote:

I thought I was in the Eos Webcam Utility section when I wrote this post. I have this problem only when using the camera as a webcam through the official software.


It sounds like you have an issue with the camera.  I suggest that you contact Canon Support.

--------------------------------------------------------
"The right mouse button is your friend."

were you able to get this resolved? i have been having the same issue.

lazona09
Apprentice

Hi I'm from the Philippines and I got the same issue.

 

But here's the behavior:

- By using OBS, it stops functioning in less then 2mins. If you would noticed, the camera blinks as if the USB cable is pulled out

 

Here's what I did:

- Same cable, I used some cheap USB hub 3.0 and it resolves the issue. If not, be sure to unistall the webcam utility and install the EOS utility. If you can control your camera using the app, it means your camera is still working properly. If not, the app will not function properly.

 

Let me know how it goes on you.

Thanks for the tip!

 

Unfortunatelly I cannot test it anymore - I sold all of my Canon gear and switched over to Sony. 🙂

KingStoic
Apprentice
were you able to get this resolved. i have been having the same issue.

AlexTischer
Contributor
Unfortunately I haven't tried anymore, but I didn't solve, so I think it wouldn't work if I tried...

KingStoic
Apprentice
After posting my question last night I went back and deleted the webcam Utility and downgraded back to the beta version and that ended up solving the issue. For whatever reason the newer webcam utility software version doesn’t like all lenses including canon lenses. Unfortunately canon no longer provides the options to download the beta version so you will need to do your research to find it. I’m not sure if I can legally make it available to you but I know that it is out there still. If you find it you’re golden.

AlexTischer
Contributor
Thank you! I'll try later on then!

claytones
Apprentice

I fixed this by changing the SD Card.

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.