Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 70D - computer doesn't recognize, and EOS Utiltiy doesn't work


Tomorrow is the deadline to return this POC. I've spent way too much time on this issue and it seems there are many many people who have also done so. First problem is Autoplay does not pop up which means the device is not recognized. Yes, I've tried all the ports. Yes, Autoplay is set to always ask with a device. I tried my Powershot and Autoplay works and it opens EOS Utility. But EOS utility is greyed out. I've called Canon support went thru everything, even installed the patch for the Utility.  No luck. Uninstalled just the Utilty and re-installed - Nada. Saw a message on some forum about hidden cannon config files..will look later as my pc is now being used for homework. But thought i'd give one last gasp, to see if anyone has a silver bullet.

Have seen lots of posts about buying a card reader - Will Canon supply a card reader? Doubtful..not one more red cent from me...


btw Window 7 sp1, EOS solution disk 28.2 + patch.


I am all of a sudden having the same issue - Windows 7 won't see my camera either through the EOS utility or as a drive in explorer. I tried switching on and off, removing the batteries and replacing, etc. It works fine if I just put the card in a reader.

Now, I did have a similar problem before with my 70D. One time it was resolved by changing the lens. Most often, EOS will SEE my camera, but when I say to download it flashes "BUSY". Busy? Doing what?

This is defined by Windows (or any operating sytem that offers similar behavior.  I'm a Mac user and I can define which applilcation is automatically launched when a device, such as my camera, is connected.)


Have you checked the Microsoft FAQ on the Windows autoplay feature?





Tim Campbell
5D III, 5D IV, 60Da

This just started happening, I have connected many times before without issue.  Also, the issue with the "busy" alert certainly isn't because the computer doesnt see it, it's a malfunction in the camera or the software itself.

Busy is not an indicator of a malfunction. When I'm imaging at the observatory my camera is under control of my image acquisition software (which in that case happens to be a program called "Backyard EOS" designed for astronomy image acquisition). The camera always says "busy" and it's normal.

I can't tell you why your camera said "busy" but it would be premature to presume that it indicates a problem with the camera.

Did you check the Windows auto-play FAQ?
Tim Campbell
5D III, 5D IV, 60Da

Two things:


In those instances, i wasn't the CAMERA that is saying BUSY, it's the EOS Utility program.  This NEVER happened to me before with my Rebel Xt, t1i, t3i, or 60D.


In this instance, I am not doing anything other than that;  and there were only a handful of photos that I had taken, it's not like it was trying to sort out hundreds of photos.  I even formatted the card in camera, took a couple more shots and tried again - still would not recognize it.

OK, I just tried something, maybe it is the answer.


I restarted my computer and tried again, didn't work.  Earlier I had also looked at my camera display and it said that WIfi was off.  I dug into the menu and saw that while it may have said off, it was enable.  So, I diabled it and voila! - it connected!


So, I suppose that could be the reason people have for not being ablle to connect, but it still doesn't explain why I sometimes get the "busy" alert in the EOS Utility.

I had the same problem-- disabling wifi worked for me as well.  Thanks!! 

disabling wifi works.


Disabling Wi-Fi was the answer! Thank you, all!

03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.