cancel
Showing results for 
Search instead for 
Did you mean: 

EOS 70D Tethering

jmperry70D
New Contributor

I have a Macbook M1 and am trying to teather my 70D. I have tried doing it by a cable and by wifi with no luck. The interface cable that came with the camera is USB1 and the M1 uses USB4 or Thunderbolt. I have a thunderbolt hub with USB connecters. I am having no luck. Everytime I try by using the EOS utility it wants to pair over wifi. I want to use my computer as the live view monitor. I can do this if I connect an hdmi cable to my tv but not the computer. The hub I have has an HDMI in on it as well. I also keep getting a message to use EOS version 2. I checked Canon's site and it is no longer available. Version 3 doesn't seem to work.

Any help would be appreciated.  Thank You

3 REPLIES 3

Version 2 of EOSU can be obtained on the Catalina OS download page.

 

Try one of these adapters:

 

Screenshot 2021-11-24 142432.jpg

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

Thank you very much. I found version 2 of EOSU.  I also ordered the USB C to USB adapters.

 

srosen
New Contributor

My newer 80D just experienced a non-tethering issue. The usual reasons are that WiFi is turned on (which disables the camera's USB port) or that the USB cable is a "power only" model that lacks the data strands per commenters. Not my issue. Although I tried after disabling Wi-Fi the newer model I have auto disconnects Wi-Fi when a cable is plugged in. t's not the cable (although I tried 2 others) since I have been using he cable for a few years. Any other fixes known? Thanks!