cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 5D Mark III Blinking ISO icon

derz1
Contributor

The ISO icon on my 5D Mark III blinks between shots  until I hit the shutter 1/2 way and it stops. Regardless of the desired setting.

2 REPLIES 2

Waddizzle
Legend
Legend

@derz1 wrote:

The ISO icon on my 5D Mark III blinks between shots  until I hit the shutter 1/2 way and it stops. Regardless of the desired setting.


You need to provide more info about your shooting conditions, shooting mode, exposure settings, etc.  

The camera causes an icon in the OVF to flash/blink is its way of calling for help.  The camera is unable to achieve a correct exposure on its own.  It will use the icon that corresponds to the setting it thinks needs your attention.  By flashing ISO, the camera is telling you that it thinks something is wrong with your current ISO setting, which is cannot automatically correct.

--------------------------------------------------------
"The right mouse button is your friend."

MikeSowsun
Authority
Authority

I have tried to get the ISO icon to flash in my 5D Mk III viewfinder and was unable. I tried all combinations of shooting modes, Safety Shift, and Auto ISO. 

It makes no sense that “ISO” should flash without even touching the shutter button and that it stops flashing when you 1/2 press.  Does “ISO” start flashing as soon as you turn the camera on? Have you tried doing a reset to clear all camera settings?

I am at a loss why your camera is doing this, and would be very interested to see the explanation if anyone has one. 

 

Mike Sowsun
Avatar
click here to view the gallery
Announcements