Showing results for 
Show  only  | Search instead for 
Did you mean: 

Damaged files on CFExpress B card in R5. Recovery?


I tried everything I can think of.  The card has been working fine but I connected it to my new laptop using a Dell Thunderbolt docking station.  I’m not 100% certain this caused the problem, but nothing else was changed.  I shot 260 images yesterday of wild birds in a local wetland area and some were among my best yet.  When the download didn’t work, I tried switching the CFExpress card reader back to my old computer, in which it worked fine.  They are both Windows based, 11 and 10 (I’m a very knowledgeable Windows and PC user).  

The systems recognize the card but now the files have “disappeared”.  They are still visible in camera and I’ve been able to recover some by wifi download and copying to the SD card.  I’ve run Data Rescue Pro and other disk software on it.  Regular software finds no errors but the rescue software can’t access the reader and card.  It seems that certain images are damaged and when the camera or computer tries to access them, it freezes up. So far, longer than my patience lasted, so I’ve pulled the camera battery to get it to unfreeze (after turning it off).  

I’ve ordered a replacement reader and card, in case that will solve the problem and I will do a deep reformat in the card before trying to use it again.  However I’d still like to recover the 60 images in the middle of the session.  When I try to copy a range of images, I can select the first and last hundred, but even the thumbnails will cause the freeze up if I try to go into the middle of the range. (Note to Canon: how about a copy by date function?)

I’d appreciate any suggestions you might have.



You lost me when you said it couldn't be read on the Dell Windows 11 machine, but worked fine on the older windows 10 PC.

Do you have your images or not?

You can set your View to list but if the files or formatting is corrupt it probably won't change the outcome. 

I typically use Photorec - CG Security for disk recovery.  Its free.   

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It

The Dell was the docking station, the Windows 11 laptop is an HP Omen i9 that I just recently got (it’s awesomely fast). 

As it happens I did manage to recover 90%+ of the photos.  I had the idea, since I could still see them on the camera, to use the R5’s second card slot to copy the files to that and use it in the laptop’s built-in SD card reader. I had to delete all the older files, which took some doing because you can’t select the date range to copy. However, by deleting the older files, I was able to get it down to just the ones I wanted, which would fit on the smaller SD card. There were still problems with the files, but I was able to use that recovery program on the SD. 200 of the files were copied Intact originally, and another 30 were recovered. Including the ones I most wanted. So, after about 24 hours of frustration, I was able to get most of them back.   The problem was some of the files were damaged. Whenever the camera tried to access them, it would freeze. By copying them to the second card, it created readable files.


Excellent work.  I would reformat the card in camera and put a "watch" on it.  Until integrity can be confirmed, I would not trust it for mission critical storage.  If it has issues again, I would pursue replacement.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It

I intend to, but I’ve always found that CFExpress card reader just a little unreliable so I decided to replace it. These cards get quite hot when transferring a lot of data, so I got one with a built-in heat sink.  I’ve already got a replacement card (Amazon same day delivery!) so I will use this as a backup, unless I can test and prove its reliable. I still think it’s the docking station that caused the problem. It had Thunderbolt ports with enough watts to run a laptop and I’m just suspicious that it fried the card and reader.


"...  I will do a deep reformat in the card before trying to use it again."


That card belongs in the circle file. Don't ever us it again.

EOS 1DX and 1D Mk IV and several lenses!
Enter for a chance to win