cancel
Showing results for 
Search instead for 
Did you mean: 

Control Ring with manual lenses and EF adapter

benwalters
New Contributor

Hi.

I have an EOS RP.

I have the Control Ring adapter connected to the camera, and an EF to M42 adapter connected to that. I have set the control ring to control ISO. I have also enabled "Release shutter without lens"... yet the control ring still doesnt work.

Any ideas?

3 REPLIES 3

Mark35mmF2
Product Expert
Product Expert

Hi there,

 

I'm not sure but I would first guess that since there is no electronic contact at the front of the adapter it is not engaging the communication. The easiest way to test if this is the case would be to mount an EF or EF-S lens on the adapter and see if the ring works.

benwalters
New Contributor
It works with all my EF glass, just fine.

My issue here really is more of a complaint I guess. Why is there a requirement for lens communication when using a feature which is entirely independent of the lens and why does it not work even with lens-free shutter release enabled. Completely bricks an amazing piece of tech.


@benwalters wrote:
It works with all my EF glass, just fine.

My issue here really is more of a complaint I guess. Why is there a requirement for lens communication when using a feature which is entirely independent of the lens and why does it not work even with lens-free shutter release enabled. Completely bricks an amazing piece of tech.

Because the adapter is designed to work all Canon EF lenses.  It is not a bug.  Find a work around and move on.

------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."