cancel
Showing results for 
Search instead for 
Did you mean: 

Connecting my T5i to a Feelworld/Neewer 759 LCD 7" field monitor

Vanon66
Enthusiast

I am trying to get my T5i set up with a Feelworld/Neewer 759 7" LCD monitor and can't seem to get the image from the camera to fill the screen on the monitor.  It worked fine with my Canon G20 camcorder so I have to believe that it has something to do with the settings in the T5i.  

 

The best I am able to get is a 5.5 inch diagonal measurement of an image and not the full 7".  It may be that there is an issue with this particular monitor working with the T5i and I was hoping that someone has had some experience with this.

17 REPLIES 17

Hi Iam having the smae issue can you help me out? I need  to shoot tomorrwo and this has been drving me nuts!!

Yes please teel u s how to fix it!! I cant find the naswer anywhewre!!

abrahamcherian
Apprentice
the frame only shows up in the centre of the monitor along with its aperture, exposure and stuffs, if i go to the monitor menu and zoom it, am loosing the exposure and aperture info

That seems familiar.  Now that you mention that, there is a setting that you have to set to make the monitor work correctly.  I will look into that today and let you know. 

abrahamcherian
Apprentice
Thanks buddy, impatiently waiting 😊

You are welcome.  And I know the feeling.  😉  

Here is the reply I made when I solved my issue.  Let me know if this works.

 

"The setting was "Camera Mode" which I set to 1080i.  Hopefully this will help someone else."  

Hello again,

 

Let me know if you have solved your issue.  Changing the resolution on mine to 1080i in the camera mode fixed mine.  If you are still having issue, there is a man on YouTube who set one of these up to his Canon 5D so he might be able to help you as well.  Here is the link to his current video.  This is about using a Panasonic, but you can contact him through this YouTube channel.  

 

https://www.youtube.com/watch?v=YT9QggIkp28

Announcements