cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon T5i (700D) shows black screen when screwing on a tripod

nhoc_quay515
Contributor

Hi everyone,

I have my Canon T5i for about 18 months when I realized whenever I put it on a tripod, the LCD screen turns black. I can still take photos using the view finder though, it just doesn't show anything in the live view. After I take my camrea off the tripod and turn it back on, it works perectly fine without a tripod. My phography intructor said it could due to the pressure when screwing the tripod to the camera base, but he has no further explanation or solution. Have anyone experienced this problem on this camera model or any other models? How can I fix this or send it to Canon to fix? If so what is the cost like in general? 

 

Thanks everyone!

15 REPLIES 15

I think there is, but they are not Canon store. It's a warehouse that sales cameras and gears in general :). But I'll definitely take my camera there and ask them.

Thanks everyone. I'll replace my tripod. Any advice for a sturdy and compact tripod for my T5i camera?


@nhoc_quay515 wrote:

Thanks everyone. I'll replace my tripod. Any advice for a sturdy and compact tripod for my T5i camera?


Beware of tripod kits.  Just like camera kits, they cut corners somewhere, and it is usually the tripod head.  If you buy a tripod kit with a ball head MAKE SURE that the ball head has a FRICTION adjustment.  A ball head is useless without it.  In fact, most heads, except for gimbals, are pretty useless without some sort of friction control.

The best way to buy a tripod is to pick out a set of sturdy legs, and to pick your ideal head.  Build your own tripod kit.  I think Benro is one of the best tripod lineups on the market for photo enthusiasts.  They also make pretty good ball heads, too.  I use the B3 ball head, on two tripods.

 

I prefer video tripods, because they are far more stable than photo-oriented tripods.  Video tripods typically lack a center column.  I also prefer tripod heads that are compatible with "Arca-Swiss" quick release mounts.

--------------------------------------------------------
"The right mouse button is your friend."


@TTMartin wrote:

@nhoc_quay515 wrote:

So I tried with the cardboards and 2 gift cards ( just to find if the surfaces make any difference) between the plate and the camera, but it did not work at all, sadly.

After I played with the mounting plate and my camera for a while, I realized few more things:

- If the camera was already on, and I tighten the plate on it (with or without the cardboards in the between), the camera worked fine (both in live view and view finder) for some time like about 20 pictures or less. Then it will show the purple-ish screen.
- If the camera was off when I tighten it, when I turned the camera on, it would show the purple-ish screen. Then when I unscrew the stud a little and switch between view finder/ live view, it goes back to normal. I dont have to turn the camera off and on again.

-Lastly, before it comeplete turns to purple-ish screen, the was some gray vignetting in 4 corners of the screen, then they quickly fade away.

 

Hope these can give you guys more clues. 🙂

 

David.


STOP USING THAT TRIPOD PLATE!!!

 

Obviously it is damaging your camera.


I have used other tripods but the camera still has the same problem. So i'm looking for a solution to fix my camera. 

On most of the Rebels, especially the newer ones like the T5i and T6i, the mother board and chassis is very close to the outside case.  I believe your tripod screw is too long and is pushing on or contacting the chassis and shorting it.  As Rebels got smaller there is less tolerance.  Even if it is not shorting it may be compressing the two together that should not be.  Stop using that tripod is good advice.

EB
EOS 1DX and 1D Mk IV and several lenses!

Is that an alignment stud on the plate?  Your Rebel has no notch for it.  

--------------------------------------------------------
"The right mouse button is your friend."
Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.