cancel
Showing results for 
Search instead for 
Did you mean: 

Canon Rebel T1i Won't write onto any SD card

tahill64
New Contributor

I know it's an old camera, but it's been giving issues recently.

 

I tried to take a picture with a SanDisk 1GB card in the camera, so it wouldn't have a hard time, but the camera just kept blinking about writing to the card. When I turn the camera off, the red light saying it was working stayed on.

 

I tried a brand new SanDisk 32 GB card hoping that because it's brand new and hasn't been used in other cameras, it would work. The camera doesn't show me the picture I took, even though I have it set for 4 seconds of showing the picture, and it takes forever to write to the card, but shows that there's nothing on the card. Even turning the camera off to get it to stop writing doesn't work. The light stays on. I even took the card out and the light stayed on. I had to take the battery out. I know it's probably not good for the camera, but I couldn't think of anything else to do.

 

Last year, I had issues where it would freeze up really bad and it had colorful lines on it. My photography instructor figured the mother board died. But it sat for a year, it turns on, the shutter works, all of the settings in manual work, it just won't actually take a picture. 

 

Is it an issue with the sensor? An issue with the card? Please help, I'd really like to have a working camera.

1 REPLY 1

Waddizzle
VIP

SD cards currently come in three varieties: SD, SDHC, and SDXC.  The difference is the storage space and the communication protocols.  The 32GB card is a SDHC card, which is probably too large for the camera to the camera to deal with.  Stick to plain SD cards, not SDHC or SDXC, with that camera.  Plain SD cards can be hard to find.

 

But, I suspect your instructor probably called it correctly a year ago.  Your camera may have seen its’ last day.

------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."