Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon R5 Freezing up


Hey there! I am experiencing a very frustrating issue with my Canon R5, mainly when shooting video. The camera will record sometimes only for a second or two, and sometimes for half a minute, and then suddenly freeze up and need to be restarted with the clip being shot nowhere to be found. This issue recently has become so unbearable that I sometimes need to restart the camera 3-5 times to get a simple 5-second clip. To even think of recording for minutes seems impossible. Occasionally the camera will also freeze up when shooting photos stating "Err 70. An error prevented shooting. Turn the camera off and on again or re-install the battery."

- This happens with multiple memory cards (CF and SD)
- Link to the CF-Express card I currently use: 
- I am using a Canon battery
- Seems to happen more often when autofocus is enabled, image is overexposed slightly (bright sky), and lens stabilization is on. 
- Occurs with all lenses (Tamron 70-200 2.8, Canon RF 24 1.8, Canon EF 50 1.8) 
- I have tried resetting the camera using this method: Reset camera under wrench menu 5 “Basic Settings only”, clear custom functions and custom settings under next menu (camera) 3&5. Turn camera off. Remove battery pack, memory card and lens. Hold down shutter button for 20 seconds. Put battery, memory card and lens back and turn camera back on.

If anyone can offer some help that would be greatly appreciated. Thanks in advance. 



Have not heard of that brand of media cards. I don’t think it’s on the list of supported cards for video.


Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers


Welcome to the forum.

Has your camera always behaved this way, or is this something new?  Do not try to update your firmware at this time.  At least, not yet.  Do check to see if your camera has the latest version.

A flawed memory card could cause the camera to freeze up when it is in use.  You might consider changing the brand.  Only purchase memory cards from Canon Authorized dealers.  I do not recommend buying them on Amazon.

Another potential cause for freezing up is Bluetooth and Wi-Fi.  Make sure your wireless communications are disabled when not in use.  I recommend setting them to [Disable}, instead of activating “Airplane Mode”.

"The right mouse button is your friend."

It's behaved this way for as long as I can remember, but it has grown worse as of lately. The camera is currently on the latest firmware, should I downgrade it?

I could look into changing the brand of the memory card, I'd be surprised if that was the issue though. That card has very good reviews. 

I'll try turning off the Wifi and Bluetooth settings. Usually, I keep them on airplane mode.

Thanks for the help! 

Turns out I am having the issue when wifi and Bluetooth are set to disable rather than airplane mode. So I guess that can be ruled out.


Sabrent products have been around a good long while.  I've used their adapters (various types) for different things PC related.  They are not top on my list of cards I'd use with my body.     

Two card brands I don't care for are Lexar and Sony Tuff....  Some people swear by them, but Lexars seem to have a higher that average failure rate and the Sony cards seem to be more finnicky about what they will or won't work with.  

I'd stick with higher end cards for reliability, and absolutely buy from a reputable vendor (mentioned earlier).  My brands of choice are SanDisk, ProGrade and Angelbird.  I use all 3 and 0 issues

The AngleBird is also a little less expensive than the Sabrent. 💰  Nothing wrong with saving a little loot when possible.  


Everyone has difference preferences and experience.  My experience might not be the same as yours.  In my experience, these cards have worked every time.  They don't glitch, freeze and luckily, I've never lost an image.  They are brands which have earned my trust.  The truth is, all hardware eventually fails, and any card can fail, even if its a brand you've used for years and trust.  

CF Express B v4 are starting to hit the market now, but there is no reason to buy these cards for the R5.

As suggested earlier, I'd look at the following:

Reset camera's main and custom settings to defaults

Use brand name cards from reputable vendors.  Ones which are certified by Canon are best

Format the card(s) in camera prior to use

Use OEM batteries which are known good condition

Use OEM lenses, or at least use a Canon adapter with a 3rd party lens that was manufactured within the last 5-8 years.

If you continue to receive err70 messages with multiple cards, batteries and various lenses, the body should be inspected by Canon.  If you can reproduce the behavior consistently, even better.

***EDIT, I have never enabled Airplane Mode.  On my T6s, 6D2 or R5 C.  I normally keep them disabled unless I am using the Canon Connect App for image transfer, GPS or time and date sync.  Note, I've never used them in Cinema OS since onboard wi-fi does not work on the R5 C except in photo mode.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks for all that info! I ordered the 1TB version of that card, I'll see if that fixes any of the issues.

Just did some more research on the card I currently have. After some digging I found that the card does 1500 MB/s write max, but only 400 MB/s sustained. That is a pretty huge gap and some seriously misleading marketing. The new card you suggested does 1550 MB/s max and 1300 MB/s sustained. I now believe the card is the issue. I went ahead and ordered that one, which arrives tomorrow. I'll have an update then. 

Glad you found the issue.

Yes, the most important metric of media cards is the sustained write speed.   This is why I personally stopped using SanDisk cards and moved to Angelbird.

SanDisk (and other brands) tend to use very large type showing theoretical max reads.  With small type for the V-rating.  And in one case of SanDisk, they didn't include any sustained write info (the V-rating) on the card or in any of their documentation.  Seemed to be they wanted to hide that info from consumers for whatever reason.   That is when they lost my trust.


Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

Still haven't completely found the solution as it's still happening with the Angelbird card, this time only less. Is the Angelbird really better than the Sandisk? The Sandisk card is officially supported by Canon. I'm debating returning the Angelbird and buying the Sandisk.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th