Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS M50 not recognising lens


I have a 11-23mm lens that I've used for months and all of a sudden my EOS M50 body won't turn on when the lens is attached. It's  working fine with all other lenses.

I've turned on the Custom Function for the camera to take pictures without a lens but the camera still doesn't turn on. And when I change to the 11-22mm lens while the camera is on, the screen is black.

When I turn the camera off, I can hear something inside moving so I think there's hope? I've cleaned the lens pins and still nothing.

There's been no known damage to the lens to cause any issues. I'm at a loss, thanks on advance for any advice/suggestions.



"I've cleaned the lens pins and still nothing."


As you have found out this never helps. I used to say it "rarely to never helps" but I have changed that statement to, it never helps. Really the only other thing you can try is a full reset of your camera. Menu>Tools>Clear all setting and Clear all custom settings. It is very important to clear all custom settings.

When that doesn't help call Canon 1 (800) 652-2666. They will probably ask you or tell you to do these things anyway but you will have already done them.

EOS 1DX and 1D Mk IV and several lenses!

Thanks for the reply, I cleared all my settings and it's still not working. It's so strange and totally out of nowhere, I can see something moving in the lens when I turn it off but that's it. Thanks anyway!