cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS 5D mark 3 stuck playback button

rechee
Apprentice

I just bought a used Canon EOS 5D mark 3 for an absolute bargain price, in a much used condition. Everything works great except the playback button. When I turn on the camera my recent images (the gallery? I don't know how it's called) come up instantly, that was already weird. After this hiccup I can close it and use the camera without a problem, takes images, focuses properly, can open the menu etc. except I can't open the gallery again. I think the button has a contact issue and the camera detects that it is always "pushed in" although it physically works okay. I have/had quite a few canon DSLRs and MILCs and I tried with them if I push the playback button while turning on, they jump right into the gallery. Tried to massage some isopropyl alcohol around the button, but the problem remains. Does anyone have an idea what can I do with it without completley disassembling the camera? Maybe is it possible to pick out the button and clean the contacts? I found out the I can map the gallery to the set button, so I can access it but it would be better to use my muscle memory to access my images.

Thanks in advance

1 REPLY 1

shadowsports
Legend
Legend

Greetings,

I was going to suggest the corner of a business card and working it around the button...  without any cleaners or chemicals.  Seems you've already given that a go without luck.  The contact may very well be bad.  

I don't usually recommend self repair for camera gear.  There is a good tear down on iFIXit for the 5D3 if all else fails.  Used, the camera ranges from $500 to $729 on KEH depending on condition.  

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements