Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS 100D problem//help!!!


I am currently doing a portfolio and took pictures this afternoon (multiple pictures) but every 30seconds to a minute my camera would stop allowing me to take pictures and come up with 'Err 02. Card cannot be accessed. Reinsert/change card or format card with camera.' so i reinserted my card, many times, and after i finished taking the photos, i tried to look at them and there were none. Just now whilst i was trying to see what i could do to it, i took a picture, of the floor, and then tried to veiw it, that worked but then when i tried to delete the picture my camera started beeping, i turned it off to stop the beeping and when i turned it back on the picture had deleted itself, this happened again but i left it on instead of turning it off when it started buzzing and it cameup with Err 02 again and deleted the picture. Please help as i am doing a photoshoot for my media project tomorrow and really need my camera for it!!!!

Thank you!


i removed the sim and switched for another sim and its kind of worked, except there is a red light that is constantly flashing???

@graceoiscott wrote:
i removed the sim and switched for another sim and its kind of worked, except there is a red light that is constantly flashing???

When you refer to it as a sim, it makes me think you're using a cell phone card with an adapter. If so, that's likely to be your problem. Try switching to a full-size SD card.

Philadelphia, Pennsylvania USA

Make sure that you format ANY new SD card in the camera, prior to use.  Never use a micro-SD card with an adapter, either.  Stick to the major brand names, like Lexar or Sandisk.  The ideal memory size seems to be 32GB, or less.  

Not every camera seems to like SDXC, >32GB, cards.  Most SDXC cards are UHS this or that compatible, which is exactly what your camera does not need.

"The right mouse button is your friend."

Thank you! The SD card I was using was a 64GB which was obviously why it wasn't working, I have switched to a 16GB which works perfectly.

08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5