Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 5D mark iii "busy" each time after switch on and missing shots...


Hi all, I am new on the forums but not new to photography and not new to Canon: shooting Canon for 30 years now, from back in the film times. Last year I sold my 5D mark ii and acquired a second-hand 5D mark iii. I acquired it from a photo store, it was in good condition, cleaned and checked.  Ever since I bought it, it shows "busy" to me after about 2 or 3 seconds after switch on. When showing "busy", it refuses to shoot anything - I simply have to wait. The "busy" time is usually some seconds but can sometimes last up to 10 seconds, or at least it feels like that: an eternity when I want to shoot that shot and my camera is refusing to do it for me. I am missing shots because of this.

Does anyone know how to fix it or what I can do?

Please note that I did search this forum for this problem, and came across this post. It seems related and there are some similarities, however there are also some differences. What is similar is that I am using an SD card (Sandisk Extreme Pro 170 MB/s 64 GB (UHS class 3, speed class 10). What is different is that I am not using burst mode.

Also note that my issue does not seem related to the speed of the card. I am an amateur with a good camera; almost never using the burst modes. And the problem occurs regardless of the fact if I have taken a photo (or not) before the "busy" message shows up. 

I have reformatted the card and resetted the camera: to no avail. Some other info: mostly shooting JPG (second best quality), enabled lens abberation correction, did not enable (white balance) auto bracketing. Lens used: any of my lenses (which are: EF 28-105 F/3.5-4.5 II USM, EF 16-35 F2.8 L USM mark ii, EF 70-200 F/4, EF 50 F/1.8, EF 100 F/2.0 USM) 

Any help or hints appreciated! 




So finally made up my mind: traded the 5D mark iii for a 6D mark ii. Problem is absent in the new camera, and I am using the same cards. Thanks everyone for helping me on this problem, unfortunately it was a camera fault. 

View solution in original post


Remove all cards and the lens. Power up the camera. --> NO "busy" message appears 

Now put the lens back on. Power up the camera. --> NO "busy" message appears 

Now insert the card again. Power up the camera. --> Yes, "busy" message appears!

So it definitely is card related, I think I can conclude? Next question, is it just my card or is it any card? I will buy and try a new card, today or tomorrow, as was suggested by Stevet1

Did you low level format the card or just format? Low level will increase the performance.

Low level formatted the card and now the "busy" message appears immediately after switching it on or waking it up from sleep. It still takes 4 to 5 seconds before I can take a picture. There was 14,88 GB worth of pictures on the card before. I will now copy those same images back to the (now low level formatted) card and see if I get the 2 to 3 seconds delay again before the "busy" message appears. 

Copied all photos back, 3153 files, 14,88 GB. Now the same behaviour is back, and on top of that, that red light on the back of the camera (bottom right) starts flashing the moment I switch it on or wake it up. Then, after some seconds, the "busy" message appears and I cannot take pictures; some seconds later "busy" is gone and I can take pictures again, however, the red light flashing continues for a while. This happens every time I wake it up or switch it on, and it never did this until after low formatting the card. 

After switching it off and on a few times, letting the red light flash and waiting until it was done, it now does not happen anymore: no more red light is flashing. However, "busy" is still there, most of the times after a few seconds, sometimes immediately: I cannot reproduce any of these two situations but can reproduce the "busy" message, every time.

Have you tried a different SD Card to see if it still happens. It could simply be a bad card causing this.


Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D

Tried a CF card, SD card removed from the slot, and the same problem occurs. It is a CF card that I owned for a number of years: Kingston CF 32GB Ultimate 266X.

So not really card related after all, but maybe more my camera's capabilities of writing to the cards, SD or CF?

Have you tried newer cards. Memory cards do wear out over time and need replacement.


Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D

Time for a new card, it sounds like. If you go for CF you will get better write speed. 5D III SD slot has around 20MB/s.

See my previous reply, same problem occurs with a CF (SD removed from the slot). Now I am wondering...

click here to view the gallery