Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cameras not recognized by computer; all but one EOS utility is greyed out.


Hello -


I want to be able to shoot tethered to my laptop, but my camera isn't being recognized correctly. In Device Manager, it appears under Other Devices, with a yellow triangle.  Right clicking for properties, yields the error The drivers for this device are not installed (Code 28).  Also, when I plug in the camera, 

"Unknown USB Device (link in Compliance Mode) pops up under Unversal Serial Bus controllers.


I have scoured the internet to find a fix, tried everything I found, and still no joy.  I have both a 6D and 60D camera that not properly recognized by my HP Envy laptop I have tried on two computers:  my desktop (which works as expected, showing the camera under portable devices), and my laptop (which is the one having issues.  Naturally, the laptop is the one I need it to work on.  Both comuters have the exact version of Windows 10:  Version 1607 (OS Build 143.1066)  Both are HP computers.  Desktop is Pavilion, Laptop is Envy.


Here is what I have tried so far:

  1. Upgraded firmware
  2. In device manager, right-clicked Update Driver Software, all say they have the best version.
  3. Tried several different USB cables
  4. Tried all three USB ports, with nothing connected to the others.  Two out of three realize something is connected.  In both of them,  "Canon Camera" now appears under "Other Devices" with a yellow triangle.
  5. When connecting the camera to either of the two ports that recognize it.  "Portable Devices" is nowhere to be found.
  6. installed and updated EOS Utility 2, and installed EOS Utility 3.  Everything in Utility2 is greyed out except for "Monitor Folder", and everything is is greyed out in Utility 3. 
  7. Tried my other camera, a 6D, on the laptop - it wasn't recognized either.
  8. Tried both cameras on my desktop computer - both were recognized
  9. Disabled, then enabled it, then scan for hardware changes.
  10. Installed Media Feature Pack for N and KN versions of Windows 10
  11. Installed the MTP Porting Kit

I am at a loss for further fixes.  I don't care about downloading files, as I just use the camera card.  I need to shoot tethered, and obviously, none of the tether features on my software will work since the camera isn't correctly recognized.

I don't want to reinstall windows, as that will be another time suck, reinstalling software, settings, license numbers, etc.

Any ideas?


That didn't help either.


I finally found a solution that worked.  Now my camera is correctly identified, and EOS Utlility works.

Went to the microsoft site and downloaded and installed Windows 10 Creator, which isn't called by the usual Windows Update.   After I installed it (takes about 2 hours), the camera is recognized, and EOS Utility works.

Here's the link:

Hope this helps someone down the road.

View solution in original post



I just want to add for future readers that might stumble across this with the same issue I had, and have tried every possible solution, as did I, that using a USB hub between the camera and laptop fixed my issue. 

We spent 3 days going through every possible solution with no dice. We finally tried a hub before giving up and it worked! We have no idea why. We're both tech literate, especially my friend, and we cannot come up with an explanation that fits. 

I know this specific case has been solved by other means, but I ran into this post and many others during my quest to solve this, and had somebody mentioned this, I would have solved it immediately. We literally tried every solution that was available on the internet, and this was the only thing that worked. So I made an account to help others who might be having the same issue.