cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera won't take picture

AlanPrather
Apprentice
Camera will focus when the button is pushed 1/2 way down and seems to do everything it is supposed to do, but it won't take the picture when the button is fully pressed.
11 REPLIES 11

AlanPrather
Apprentice
Forgot to mention; it's a Rebel 2Ti

ScottyP
Authority
What shooting mode are you in? It sounds like the camera knows you don't have enough light to make a proper exposure.
Scott

Canon 5d mk 4, Canon 6D, EF 70-200mm L f/2.8 IS mk2; EF 16-35 f/2.8 L mk. III; Sigma 35mm f/1.4 "Art" EF 100mm f/2.8L Macro; EF 85mm f/1.8; EF 1.4x extender mk. 3; EF 24-105 f/4 L; EF-S 17-55mm f/2.8 IS; 3x Phottix Mitros+ speedlites

Why do so many people say "FER-tographer"? Do they take "fertographs"?

Thanks for yhe response. I tried several shooting modes and it made no difference. In automatic mode the flash pops up but the camera won't allow me to shoot.

How long have you had this camera? If it has been a while, is this a new problem?
Scott

Canon 5d mk 4, Canon 6D, EF 70-200mm L f/2.8 IS mk2; EF 16-35 f/2.8 L mk. III; Sigma 35mm f/1.4 "Art" EF 100mm f/2.8L Macro; EF 85mm f/1.8; EF 1.4x extender mk. 3; EF 24-105 f/4 L; EF-S 17-55mm f/2.8 IS; 3x Phottix Mitros+ speedlites

Why do so many people say "FER-tographer"? Do they take "fertographs"?

TCampbell
Elite
Elite

Alan,

 

There are a few things to check...  

 

1)  Have you verified that the camera isn't in a timed delay mode (e.g. it's not set for the 10 second timer?).  

 

2)  If you are in "One Shot" mode, the camera will default to "Focus Priority" which means it will refuse to take a shot if it cannot confirm that the camera was able to lock focus on at least one focus point.   If you are in "One Shot" mode and in poor lighting, the camera may simply refuse to take a shot.  This is normal -- not a defect.  You can override this by switching off auto-focus (go to manual focus on the lens) or by switching to "AI Servo" mode (which changes the behavior to "Release Priority" whcih means the camera will take the shot when the shutter button is fully pressed... even if it believes it was not able to focus.)

 

3)  Are you in a situation with very low light?  The camera may give up attempting to focus if the lighting is not adequate to lock focus.  You can test by checking the camera outdoors during the daytime when there's plenty of available light.

 

There are a few other things which are a bit more obscure and/or a bit more obvious.  The camera wont take a shot if it does not believe there's a memory card in the camera -- but it should also give you an error message that there's no card.  I just want to confirm that you do have a card installed and the camera believes there is a card installed.

 

There's also a custom mode in which you have to press the shutter button twice to get the camera to take a shot.  The mode is intended for situations where the vibration induced by the mirror swinging up may blur the shot.  One press of the button makes the mirror swing up (you would normally pause a moment) and the second press of the button makes the shutter release.  Typically you'd only use this mode with a remote release and a tripod.  It's unlikely you'd stumble onto this mode accidentally... but if you did, the camera will not take a shot on a single button press -- you have to press the shutter button (fully) twice before it will take the shot.

 

 

Tim Campbell
5D III, 5D IV, 60Da

Thank you Tim! Somehow I had switched to "One Shot" mode and I was shooting in poor lighting. Auto wasn't on so I checked by "AI Servo" mode and that was it! Much thanks to a full explanation and a couple of options for solving my issue. So easy!

TCampbell, You're  **bleep**ing G Thank you so much!! I was struggling and your instructions really helped me!! 

Hi Tim:

 

I found your response to why Canon cameras won't allow users to take the photo very helpful. I am hoping someone can help me with this one. 

 

Camera:  Canon R5

Lens:  Rokinon 14mm

Attempted shot:  Star photography

ISO:  3200

Focus:  Manual

Shooting Mode:  Time Value

Time:  30 seconds

 

The lens was securely connected to the lens adapter. The Rokinon was set to F2.8 and infinity focus. But the R5 would not allow me to take the shot. I took the Rokinon off of my R5 and put it on my 5D Mark III and had not problem taking the shots with very similar settings. Any suggestions on what I should check in order to get the R5 to take the shot?

 

There is a setting which allows the R5 to take an image without a lens.

Avatar
click here to view the gallery
Announcements