cancel
Showing results for 
Search instead for 
Did you mean: 

Camera problems

Barry65
Contributor

I have had problems with 70D and 90D. A black streak goes across the image making the camera unusable. What am I doing wrong?

16 REPLIES 16

kvbarkley
VIP

Post a picture, but it appears you have a broken shutter.

Camera problem - BH 9-14-2021.jpg

That does look like a failing shutter. Are you saying that both your 70D and 90D have the same problem?

Mike Sowsun
80D, 5D Mk III

I have had 2 70D cameras and one 90D camera with the same problem. Just trying to see if I'm doing something wrong. the problem has happened while I was using a Canon 70-200m lens.

It seems highly unlikely that all 3 of your cameras have a failing shutter.

 

I would suspect a lens problem in your case. You may have an aperture blade failing on the lens. Does the problem only happen with that one lens?

Mike Sowsun
80D, 5D Mk III

The lens has worked fine on other cameras. Can the lens cause a problem with the camera?


@Barry65 wrote:

The lens has worked fine on other cameras. Can the lens cause a problem with the camera?


Worked fine on other cameras at the same time as the three cameras you mentioned have a problem, or worked fine at other times?

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

I have used the Canon 70-200 lens for 5 and a half years on three different Canon cameras: 2 70 D's and one 90D. My problems with all three cameras happened when I was using that lens. In other words, after I couldn't use one Canon camera anymore, I used the lens on the next Canon I bought and it worked until the same problem happened. And then again with the 90D which failed last night.

I have a remaining 70D and the 70-200 lens is working on that camera. Could the lens cause damage to the camera?

Announcements