cancel
Showing results for 
Search instead for 
Did you mean: 

Bizzare T5i Error 01 Situation

dimsh2000
New Contributor

I'm having a strange issue with a Canon T5i. It's the famous Err 01, but none of the solutions I've searched online work. I have the kit 18-55mm lens, 70-300 IS USM telephoto lens, and a 15-85 IS USM lens. All three lenses work just fine on other cameras I have (70D, T6i). However, on the T5i I'm getting the following:

 

1. 15-85 IS USM lens communicates, autofocus works intermittently, and Err 01 pops up half the time

2. 70-300 IS USM lens doesn't autofocus at all, no communication, no Err 01

3. 18-55 kit lens works fine with zero error

 

I've tried all the fixes I've seen online and the issue still persists. Cleaned the contacts on both the camera and lenses, played around with apeture settings, updated firmware, tried different sequences of turning the camera on and off and adjusting apetures. I've even replaced the contact pins on the camera to brand new ones and the error still persist in the same fashion.

 

Any idea what this could be? Any help would be greatly appreciated.

2 REPLIES 2

shadowsports
Esteemed Contributor

Greetings,

The Canon recommended solution is straight forward.

 

Clean the electrical contacts on the camera and lens.
Use a Canon lens.
If the instructions above do not solve the problem, please contact your nearest Canon Service Center

~Rick
Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6

ebiggs1
Forum Elite

"Cleaned the contacts on both the camera and lenses, played around with apeture settings, updated firmware, tried different sequences of turning the camera on and off and adjusting apetures. I've even replaced the contact pins on the camera to brand new ones and the error still persist in the same fashion."

 

Actually none of what you did is going to correct the problem and the last thing you did probably made sure of that. If resetting the camera back to defaults doesn't fix the issue you need to seek professional service.  However it may be beyond the cost of a used working T5i.  Cut your lose as you have a T6i to use which is working.

EB
EOS 1DX and 1D Mk IV and several lenses!