Showing results for 
Show  only  | Search instead for 
Did you mean: 

Area selection zones not working

Someone please point out my foolish error.

The M-Fn button won't toggle through the different AF Selection modes.

Canon 5D Mark III
Manual mode
One Shot

I have selected all (or other combinations) of AF area selection modes from AF menu 4 (which means I should be able to toggle between them with the M-Fn button after pressing the AF Point Selection Button.

I should be able to:
Press the AF Point Selection Button (the one on the upper right that looks like a checkerboard)
Press M-Fn one or more times to toggle through AF area selection modes (Spot AF, Expand AF Area, Expand AF Area Surround, Manual Select or Auto Selection of 61 pt AF).
What is actually does is just toggle off/on the indicator in the viewfinder that show which AF point is selected (not the selection mode).

I also tried in on AI Servo, with the same response.

And, yes, I did check to make sure that the AF area selection method is set to M-Fn in AF Menu 4 (and not to Main Dial).

I also tried with two different lenses, since some of the focus system functionality is lens dependent.

What have I got set somewhere to restrict this functionality?

if you mean C! C2 C3 yes i cleared those. i managed to get AF selection using the wheel on top, M-Fn still not working, i negated all the lock settings. Custom controlsCFn2 M-Fn to FEL which is the same as my other 5D3

@AndyShust wrote:

Hello everyone.


I bumped into this problem some days ago. Only resetting camera settings (not custom functions) helped. I thought it would be useful to write this here.


Still no cue why the AF selection stopped working. I suspect connecting my camera to an Android tablet with DSLR Controller app, which might have messed up or locked the ability to choose AF points.

Ok so I'm not going crazy, glad I found this thread. My ability to change to manual autofocus point has gone away too. And I suspected it may be related to connecting my camera to my tablet through DSLR Controller. Seems like I'm not the only one this has happened to. Hopefully resetting all settings fixes it for me too.

Quick edit - resetting the settings fixed it for me. It's too bad DSLR Controller may have caused this, because I love that app!

It now works when I use the front wheel, have not done upgrade in firmware yet.