Showing results for 
Show  only  | Search instead for 
Did you mean: 

6D Mark II Locked on Error 70


After struggling for an hour or so with third-party camera-control software I ended up with an ERR 70 on my 6d Mk II.


The software that I was using is from a reputable developer; it is widely used by astrophotographers and I have been using it for years with various Canon DSLRs without a problem. This is my first attempt to use it with the 6D Mk II. Sometimes it worked, sometimes the software would fail to connect to the camera. It was in the course of troubleshooting this problem that I ended up with  ERR 70.


Possible bugs in the interaction between Mac OS High Sierra and the camera could be at fault.


In any case, I ended up with  ERR 70. Removing the battery for a couple of hours didn't help.Changing lenses didn't help. Reformatting the SD card didn't help. Other ideas most welcome.




David aka Davoud


@Davoud wrote:

@Ray-uk wrote:

Remove battery, lens and memory card. Close battery and memory card doors.

Turn power switch to ON position, press shutter button and hold for 30 seconds to 1 minute. Turn power switch OFF.

This should clear internal memory and reset to factory conditions.

Refit battery, close door, turn power switch ON.

Thanks for taking time to reply. Sounded good—something I had not tried. Alas, it didn't help. Appreciate it anyway.



From what's been said so far, this sounds like the sort of problem that might call for a firmware update. Have you made sure that you're using the latest firmware version? (I'm assuming that a firmware update can be done in C1 or C2 mode, though it's something I've never tried.)

Philadelphia, Pennsylvania USA

I had this same error. In my case this advice worked and the camera came back on but reported a problem with the card. I reformatted it and I'm back in business. Thanks Ray-uk!

I was able to get the camera displays turned back on and most functions work, BUT.......I cannot switch out of C1 or C2.  As soon as I switch to any other mode, the camera goes dark, and nothing works except the flashing err 70 in the little display on the top right of the camera.


I have reformatted the card to no avail.   If I switch to any other mode, I have tp remove and reinstall the battery before I can get the camera back on in C1 or C2.


Is there a solution to all of this.   All I did was download a very popular astrophotography image capture program and plug the camera into my laptop.   Apparently the 6D Mkii didn't like that for some reason.   I have used that program for years with other Canon cameras with no problem.   


Also, if I try to go back to factory settings............the camera will not do that in C1 or C2 modes.   Catch 22!!  


Now what?

This seems to have worked for me but time will tell. Only got the error 70 when turning the video on and sometimes it would within seconds and other times it maybe a minute or two before the error! I will test it on my gimbal, which is when the error appears within seconds. Thanks for this tip as you may have just saved me $400+ to get the camera repaired.


Did you ever get the issue resolved?   If so, how?   I can only use my 6D Mkii in C1 or C2 mode.   In any other mode the camera goes dark and nothing works..........except the blinking err 70 on the little display on the top right of the camera.



Did you ever get the issue resolved? If so, how?


Easy. I sent the camera to Canon for repair. They repaired it under warranty and it has worked flawlessly ever since. That was more than 14 months ago, I believe.


Is the third-party control software something that changes/"enhances" the camera's firmware? If not installed carefully and correctly, you could have damaged it. Like a BIOS update on a computer going wrong. When that happens one ends up with a non-functioning brick.