cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

5d Mark III not downloading RAW

pgsdeepak
Contributor

Got my 5D Mark III a couple of days back. I took a few pictures in RAW-JPEG. While I tried to download, it launches EOS Utility(latest version) and hangs. I tried the same CF card on 40D and it was able to import without problem. I tried other software like Picasa, Adobe Bridge, iPhoto, Picasa and Adobe are not able to connect to the camera. EOS Utility is able to connect and I was able to remotely control the camera and take photos. I was able to download JPEG only files as well. But when it comes to Raw, the software goes unresponsive and loses connection. Once in a while everything works fine as well (even RAW), that is the strange part

My Computer and softwares are up-to-date. Infact the 5D MIII I got through CPS Load worked fine without issues. I also made sure the CF Card and Cable are also fine. 
Is it a known problem? or should I return the camera. Thanks in advance for your response

23 REPLIES 23

Like I said earlier, I am not a Mac user but my photog friends that do, tell me they have problems. And the problems are as you have described them. Very erratic, working and not working. Mostly not. I attended a class on LR 4 recently and the instructor warned us to not use Lion and LR4. That is the extent of the help I can offer.

Sorry,

EB

EB
EOS 1DX and 1D Mk IV and less lenses then before!

Thanks ebiggs1. You and marcosf made me feel better. I had done a lot of search in the internet and could not find much luck. Atleast now I feel that I am not alone and that it is some compatibility issue with mac. Feeling relieved that the camera is fine. I will get a card reader as that sounds like the only option at this point. thanks again.

After the new firmware upgrade, all is good. I can download without issues. Before I ordered a CF card reader, i was able to do the firmware update, so saved some money as well 🙂

thanks all who took time to respond

ebiggs1
Legend
Legend

I am not sure what computer you are using. Is it a Mac or PC? If it is a Mac and you have Lion, there are know issues with it, and at least LR and PS CS6. I am not a Mac user but my friends that are tell me about it.

I will make a left field guess, it is not the 5D Mk III so returning it to Amazon will not help.

EB
EOS 1DX and 1D Mk IV and less lenses then before!
Avatar
click here to view the gallery
Announcements