Showing results for 
Show  only  | Search instead for 
Did you mean: 

5D Mk2 - Cannot format CF card


I was given a 5D Mk2 by a colleague, but it when turned on, it says the CF card needs to be formatted, and when I try to do that through the menu item, it says it cannot format the card, put in another one.

Now, I have a CF card reader on a PC, and I've formatted it as FAT32, as that seems as though it should be formatted as when I've searched for info, but it still isn't happy with the card.

The pins in the card slot seem to be ok, card feels ok when it goes in too.

The cards I've tried are Lexar Pro 400x 16GB UDMA, but I've also tried a really old 64MB Cisco Systems card I had in a box.

A bit more searching around, I see other people having the same problem, but never seem to reach a satisfactory conclusion, so I was wondering if anyone here knew what the issue is likely to be, is it a chip gone faulty, bad internal connections? If I thought there was a chance of fixing it by going inside, then I might have a go.



You can use this as a guide.  

Canon EOS 5D Mark II - Compatible Memory Cards (

Remove / disconnect all accessories from the camera.  Are you able to perform a factory reset? (Main and custom settings)

If after trying one or two compatible cards, which are verified working, its safe to assume the problem is with the camera.  Sometimes people give their problems away.  That might be what's happened here.  Repair is probably not worth it.  If you want to investigate that, try midwestcamera dot com.  Keeping in mind that a used mkII replacement starts at $250 and goes up to about $430    

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It


It's a longshot, but this is what I'd try next. It's easy and quick and most importantly FREE! Open your CF cards on your laptop or desktop. Re-forrmat the cards as something other than FAT, like maybe NTFS. Then try to format them in the camera again. If that's still a no-go in the camera, format them again with your desktop as FAT32 and try them again in the camera. Even if all that still doesn't get you anywhere it hasn't cost you much in time and effort. Did I also mention that it's FREE?

While you're at it, make sure the date and time are set properly in the camera. Don't imagine it would make any difference but who knows.


CF card is more similar to a memory chip than a random access storage device.  It is already pre-formatted.  All that you are doing is erasing what may be stored in the memory chip(s) inside the memory card. The formatting process should also identity bad memory locations, and flag them as such..

"The right mouse button is your friend."