cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Windows 10 not recognizing the scanner on my MX472

bugmenot9
Apprentice

I recently got a new computer and when I went to use the scanner on my MX472 today, it recognized everything but the scanner. I checked in the settings and I've got nothing in the selection drop-down for scanner, though I have 3 choices of printer. I tried plugging the USB cable in and it still refuses to recognize the scanner.

3 REPLIES 3

Patrick
Product Expert
Product Expert

Hi bugmenot9,

 

Reinstalling will resolve this issue.  To do this, please disconnect the USB cable from your PIXMA MX472 follow these steps:

 

 1.  Press the Windows key on your keyboard and the letter R, then let both go.

 

 2.  In the Run window, please type CONTROL PANEL and click OK.

 

 3.  Click on View devices and printers (or Devices and printers, depending on your view).

 

 4.  Right click the Canon MX470 series and left click on Remove device.  Repeat until all MX470's are removed.

 

 5.  In the upper left corner, click on Control Panel (or the Back button).

 

 6.  In Control Panel, click on Uninstall a program (or Programs and features, depending on your view).

 

 7.  Click once on "Canon MX470 series MP Drivers" and then click Uninstall at the top.

 

 8.  Follow the on screen prompts to uninstall the driver.  When you click Complete,  the driver is uninstalled.

 

 9.  Once done, please reboot your computer.

 

When your computer restarts, we will reinstall:

 

 1.  Please use the following link:

 

https://www.usa.canon.com/internet/portal/us/home/support/details/printers/inkjet-multifunction/mx-s...

 

 2.  Click the Select button next to "MX470 series MP Drivers Ver.1.02 (Windows)".

 

 3.  Click the Download button.  The drivers will download.

 

 4.  Once the download is complete, open your downloads folder.  To access this, press CTRL and J, then let both go.

 

 5.  Double click "mp68-win-mx470-1_02-ea33_3.exe" to begin the installation.

 

 6.  Follow the on screen prompts to reinstall.

 

Once the installation has completed, please attempt to scan:

 

 1.  Click on the Windows Start button in the lower left corner.

 

 2.  In the menu that appears, click on the Canon Utilities folder.

 

 3.  Click on the IJ Scan Utility.

 

Please use the IJ Scan Utility to perform your scan.

 

For more information regarding the IJ Scan Utility, please use this link:

 

https://ij.manual.canon/ij/webmanual/ScanUtility/W/MX470%20series/1.1/EN/SU/Top.html

 

 

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

jstagliano
Apprentice

I have the same issue. The presented solution does not work.

jstagliano
Apprentice

I thought I'd follow-up. I could not get it to work with my main computer, a Dell XPS running Windows 10. Printing worked just fine just couldn't detect the scanner.

With my gaming laptop (Acer) I was able to install drivers (from CD, the drivers downloaded from the Canon tech support have not worked with any system I have tried)  and it worked as expected. Basically, I am assuming there is something with the Dell that is causing issues with the scanning software

 

Avatar
click here to view the gallery
Announcements