Showing results for 
Show  only  | Search instead for 
Did you mean: 

Selphy CP 910 keeps jamming but it isn't jammed.


My Canon SElphy CP910 keeps saying that there is a paper jam but the paper never actually enters the printer. I have followed the instructuions multiple times by turning it off and on, disconnecting the paper tray, refilling the paper tray with fresh paper, and even taking out the ink cassette and putting it back in but it will not print or get past the paper jam that isn't actually there. Someone help, please. Thank you in advanced. 



Hi alyssacharity,


Since the paper will not feed in the printer, and the printer continues to think that there is a jam in the unit when there is not one, the printer may require servicing.  We ask that you please contact a Canon technical support representative at one of the methods provided here for further assistance.  A representative will be happy to assist you free of charge.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I have the same problem. How can I get in touch with a Canon technical support representative?

Hi, Jaapdewitjr!

Thanks for posting on our forum! This community is designed for your fellow Canon owners to help each other out with any problems they may encounter. If this is a time-sensitive matter, search our knowledge base or contact our US-based technical support team at

Thanks and have a great day!

I'm having exact same problem. Did you ever find a solution? If so, do you mind telling me how you fixed it? Thanx

Take an alcohol wipe to the paper rollers in the printer


Selphy CP910:  The screen indicates paper jam but the paper isn't feeding.  Would appreciate knowing if others have encountered this problem and, if so, whether the problem has been resolved.  Thanks.

It's ridiculous, but all you have to do is clean the grey wheels which pull in the paper. If you haven't used it for a long time. Found this solution when looking for the error that occurred after filling the printer up with a lot of paper, which helped me for this error message but not for the one to follow (wrong paper format). And it worked
I think it was those clean looking wheels which needed to be cleaned anyway.

Thanks so much! This worked for me. I was able to print a photo after cleaning the rollers with a (new) toothbrush. Very relieved!
Thanks for the info!

Thanks so much for this information.  We tried and tried to get it to print, but no luck until we cleaned the wheels.  Now the printer works great!