cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Printer will not stay on

thomam37
Apprentice

I have an MG6620 printer, and today it decided to not stay on after the initial turn on.  Any suggestions.  Already unplugged for a few minutes and tried again.  It comes on for about 10 seconds then turns off. 

7 REPLIES 7

johnfasc
Apprentice

There are other threads with many having the same issue. I am also.  Too many with the same issue for it to be a machine problem.  It has to be something Canon sent down or a bug.

 

kiiks67
Apprentice

I'm experiencing this too. I tried printing last night but the printer would not stay on. I was able to print successfully over the weekend.

sheri99
Enthusiast

Anybody find a solution?  This is also happening to me.

Olmbre
Contributor

Same machine, same problem, same time frame! Not a coincidence!!

sheri99
Enthusiast

SOLUTION: After a 1:57 hold time with Canon customer service.... I have the solution! (and that was 2 hours, not 2 minutes) If this is happening to you it is very easily fixed. [Removed per Community Guidelines]  Although I wish I could sell it to make up for my 2 + hours of time.  Here is what you need to do to fix it:

Completely unplug your router and then turn on your printer (it won't stay on if your router is because of a linking problem with the router, that we are going to fix.)  So this is the step-by-step for the MG6620 and probably those models with similar menus, but whatever model you have just try to get to your DNS Server Setup. That is where the setting is that needs manually changed. So for the MG6620:

On the menu swipe to Setup, then find Web Service Setup then DNS Server Setup. Select Manual.  Press each set of numbers and change them all to 000 except the last set. That needs to be 001. So your DNS will look like this: 000.000.000.001  Click OK, then click No.

That's it. You should be good to print.

You are welcome!  Too bad someone at Canon doesn't just post this somewhere. Would've save a lot of people a lot of headaches, I'm sure. 

 

This worked for me as well. 👍🏼

I don't recall why there was a need to connect to the web (hence the need for DNS) if you only need local printing wirelessly. I can't wrap my head around this. (My brain ain't as young as it used to be.)

It works with all devices tried. Great work Sheri!

 

geocoffey
Apprentice

Thank you for your time.  Did they mention why this happened?  I isn't coincidence that this printer (and others on another feed) are having this issue.  I can't test the fix tonight because I won't turn off my router now.  

Again, thank you for your time.

Avatar
click here to view the gallery
Announcements