Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIxma 8500 prints with no ink


I have tried all the obvious thinks - I have ink and did a deep clean. However, when printing a test page ( or any thing for that matter) absolutely no ink ends up on the page.  It is not faded - it is completely without any ink.   


Any advice?






We need some back story please.


New printer, used printer?


Worked / never worked previously?


New ink installed > If nozzle checks and cleaning cycles are blank, this would likely indicate a problem with the printhead.



Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks for engaging. I have had the printer for a long while. I bought it new  ( ~10 years ago - maybe longer) and it has worked well up to this point. I do not use it that often. It was probably 2 months in between a successful print and now, where it is printing no ink at all.  Yes, I have done the Nozzle Check, Cleaning and Deep Cleaning to no success.


It is faily odd to me that it just went fro working to not working in such a binary way. I was suspecting something to do with the print drying due to gap between use, but the fact it is not printing any ink makes that unlikely.


How can I confirm a printer head failure? Is it fixable, or given its age, likely a new printer would make more sense?



click here to view the gallery