Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIXMA TS6420a won't print from Chromebook after clearing a paper jam


hi, i have been using a relatively new TS6400 pixma without problem with my chromebook for the past several months.  Tonight I had a paper jam, and I cleared the jam, and while the printer will still print using the photocopy function, it does absolutely nothing when I try and print anything from my Chromebook.  I have no idea if this is a chromebook issue or a canon issue.  The print queue says the printing was complete, but the printer just sits there like a giant expensive teenage paperweight.  Any ideas on how to fix this problem?  Tried turning both the Chromebook and the printer off, and shutting both down, and reconnecting the printer to wireless router but nothing has worked so far.




So that the Community can help you better, we will need to know more information.

What is the exact model printer you're using (For example, PIXMA TS6420 or TS6420a. It's usually on the top or front of the unit)?

Do you see any error messages?

Any other details you'd like to give will only help the Community better understand your issue.

If you're in the United States, and this is an urgent support need, please click HERE to visit your My Canon Account to discover your personalized support options.

If you're outside the USA, please click HERE to find support options in your country.

Thanks and have a great day!

Hi, It's a Pixma TS6420a.  It was working until there was a 2 piece paper jam.  I opened the top and had to pull out the paper from behind the printer cartridges and I am concerned that they might have touched the clear film as they were jammed pretty bad in there.  I didn't touch anything except the paper and the ink cartridges and the white cable thing that connects the ink cartridges to ...  something.  Anyway, since I pulled the paper out the printer will not print - not sure if it's relevant or to the paper jam or not. there is nothing left of the paper jam.  When I print from the Chromebook, it has a green dot next to the printer icon, it goes into the print queue, and then says it has printed. there are no error messages on the chromebook or the printer.

The printer itself does nothing - does not even attempt to pull the paper through.  Works fine otherwise except for trying to print.

Product Expert
Product Expert


If your able to make a copy directly from the printer and there is no error on the printer, then there should be no hardware issue. 

If you have an Android or iOS phone, try downloading our free Canon print inkjet selphy app and see if you can print. 

If you are able to print from the app, then the issue is on the Chromebook and you can try going into the setting on Chromebook to remove and add the printer back on. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.