cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maxify GX7020 prints and scans, but won't copy

davidbaril
Apprentice

Hi,

I have a one month old Maxify GX7020 multifunction printer that will print and scan from multiple Windows 10 PCs, smartphones, and tablets, but will NOT copy.

 

I can set up a copy from the operator's console and preview the page correctly ... but when you hit the color or black-and-white copy button, the printer seems to scan the page, and then prints a blank page.

 

I have tried copying from the platten and the ADF (single or dual-sided) and I still get blank pages.

 

I can scan into the computer the same page, either from the platten or the ADF, and the source document will scan fine.  I can then take the resulting PDF file and print to the printer ... and it prints correctly.

 

The printer is running version 1.050 and is connected to hard-wired Ethernet.  Printer Wi-Fi or USB connections are not being used.

 

The printer WAS copying properly several weeks ago using the ADF.  I believe this was before the printer updated its firmware across the network.  I manually logged into the printer and verified the firmware version.

 

The GX7020 support site indicates that version 1.050 is the latest firmware version.

 

There is a Windows firmware updater program download available to update the firmware to version 1.050 via a USB connection ... which I did not need to use.  The printer updated the firmware itself, displaying a message on the console for permission to update the firmware ... which took several minutes.  This happened several weeks ago.

 

I tried turning the printer off using the power button, then disconnecting the power cable for 30 seconds and then reconnecting the power and turning the printer back on ... and no change in symptoms.

 

I will be calling support Monday morning and asking for a resolution to this problem, or I will be returning the printer that is less than 2 months old. It is an expensive printer and no longer copies.

 

Any suggestions?

0 REPLIES 0
Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.