Showing results for 
Show  only  | Search instead for 
Did you mean: 

Filter fail message with Canon MP490


Hoping someone can assist, as I've been trying for some time now to connect my Canon MP490 printer—which has previously functioned perfectly—to my new Macbook, and cannot seem to find a solution.


I've tried deleting the printer and reinstalling it as advised by others on this forum, but my problem is that when I go to the Canon website to download the driver, it says "There is no driver for the OS Version you selected. The driver may be included in your OS or you may not need a driver." This is the case for all of the most recent operating systems, going all the way back to Mac OS Sierra v10.12. I tried printing without installing a driver and got an error message. So I tried downloading the Sierra driver since that appears to be the most recent version, but also got an error and was unable to install.

Is there any way to run this particular printer on newer operating systems, or do I need to get a new printer?? I don't want to get a new one until I'm sure I've exhausted all options, so hoping someone here has insight. Canon Support won't help because the model is too old to provide tech assistance with apparently.



macOS Sierra was the last 32-bit version of macOS.

About Mojave (macOS 10.14) and 32-bit Apps - The Mac Observer

Your printer driver, since it is an older printer, is most likely 32-bit.

I don't think you will be able to get your printer to work with your new computer.

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic


Try Printopia..there's a free trial & it only costs $19.95 if it works for you.

It works for me for a PIXMA MP490 under MacOs Monterey

MP490 wouldn't work when I upgraded to MacOS Monterey - because Canon never updated their printer driver.  The printer is only used lightly and worked well prior to the OS  upgrade.  I had just bought a fresh set of inks.   Canon's only suggestion was upgrade to a new printer, even though the MP490 was completely operative.   I found a 3rd party app called Printopia which for $19.95 provides printing support for the MP490 under Monterey,

Canon should be shamed for trying to force obsolescence on a perfectly good piece of hardware and for their greed in trying to make me buy a new printer. 


I had a “filter” fail error on Canon Image Class MF3010 both trying to print online as well as when downloaded on to my Mac Sonoma 14.2.1 computer. The solution was to Control + click on the name of the file on my computer in Finder, Open With, Change to Mozilla Firefox. It would open and then print.   ..    ..    ..   Then I changed the default PDF viewer on my Mac computer which was Preview. It wasn’t working on my Mac giving me the “filter” error. I Control clicked the name again, clicked Get Info, then scrolled down to Open With and the drop down menu has Default, click that and scroll down to Firefox and make that your default Open With.  Wishing everyone drama-free printing!

click here to view the gallery