cancel
Showing results for 
Search instead for 
Did you mean: 

Canon TS6320 fails to print unless I run the Windows printer troubleshooter

tcreek
Contributor

I am on the Windows Insider Beta Channel and the printer worked OK until a couple of weeks ago.

When I attempt to print on a Canon TS6320 USB printer on Windows 11 I receive a message on the printer screen showing  "Processing … please wait momentarily" and it never prints ." A message on the computer screen shows "Printer not responding." When I run the Printer troubleshooter at Windows Settings it completes showing no issues but then the printer will immediately print the page that I had previously loaded.

I have re-installed the Canon drivers and installation software and have run chkdsk /f r and DISM on the PC. The USB ports show OK at Device Manager. The Print Spooler was reset is set correctly.

5 REPLIES 5

ArthurJ
Product Expert
Product Expert

Hi,

I recommend to have this issue looked at by our support team. Canon does have a chat team that would be happy to assist you with this issue. Please click HERE and in the chat/ask a question box that appears, ask the chat bot to speak to a live person. Our chat agents are available Monday-Friday 8:00 am to 8:00 pm ET, excluding holidays.

We look forward to hearing from you

tcreek
Contributor

I do not believe Canon support could solve the problem because, to me, it is obviously a problem with the Windows 11 Insider Beta and/or Dev Channel recent updates not being compatible with the Canon TS6320 printer drivers.

I have connected the Canon TS6320 to another Windows 11 PC on the regular Windows 11 channel and it operates normally.

Another unusual problem on the Insider Channel PC is that when turning the printer off, the Canon screen says "turning off…please wait momentarily" and it never turns off. No printer menu buttons are active to operate screen functions and the power plug must be removed to turn off the printer.

Thanks for your input.

tcreek
Contributor

There is obviously a serious problem with Windows Insider build 22616 of May 5 in the operation of the Canon TS6320 printer. My TS6320 worked perfectly until that build. Now there all kind of glitches when attempting to print. The TS6320 works perfectly on other Windows 11 PCs that are not on an Insider Channel. And after you connect the TS6320 to the PC on the Insider Channel it will not print on a regular PC unless the Canon drivers are uninstalled and reinstalled. I switched the printer back and forth 3 times and each time I had to reinstall the drivers to enable the printer to operate on a non-Insider PC.

shadowsports
Elite

Greetings,

General rule of thumb for this.  Canon (and others) do not support beta or insider builds of Windows or Mac OS.  They aren't necessarily bad, but are frequently changed making them less reliable for production environments.  If you want /need reliable printing, it's best to go with a compatible version of your OS.  One which is tested and certified.  Anything else is a gamble.  Results can vary and compatibility is not garunteed.  

 

 

~Rick
Bay Area - CA
~R5C (1.0.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra
~ImageClass MF644Cdw ~Pixel6 
~6D2 (v1.1.1) retiring

After 3 weeks of problems with the Canon TS6320 printer failing to be recognized on two Dell Windows 11 PCs, one on the Beta Insider Channel and the other on the regular release channel, here is the bottom line as far as I can determine.

The Windows 11 PC, after the Insider Channel build #22616 of May 5, will not recognize the Canon TS6320 no matter what solution is tried.

The Windows 11 PC on the regular release channel will not recognize the Canon TS6320 unless the Canon MP drivers are deleted and reinstalled. The printer then operates normally until there is another Windows 11 update. Then the printer is not recognized unless the Canon MP drivers are deleted and reinstalled. I have done this three times and the printer is working fine now, probably until the next Windows 11 update. Or maybe somewhere, somehow the problem is fixed.

Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM