cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon MX715

limtu
Apprentice

Hello, I'm having some troubles with my printer Canon pixma MX 715. 

 

IMAG1411.jpg

 

I had bought it around 3 years ago, it was working fine until I left the unit alone in disuse for approx 4 months. When I went to use it again, ofcourse my nozzles were clogged and I recieved the printhead error message.

 

I bought a new printhead QY6 - 0080, for £60, approx $90-100. I didnt have any other errors other than to replace the printhead. Once i removed and replaced the old printhead with the new one, it all seemed to be registering fine.

IMAG1406.jpg

 

I bought 2 new sets of ink (XL) - I went to run a 'nozzle check' and the machines starts moving. The noises of the printhead moving back and forth indicate something is happening; However as it was printing, blank pages came out, with no traces of ink on the paper.

 

IMAG1407.jpg

 

I ran 'clean' and tried again, still nothing, even though the ink levels in the cartridges was dropping.

 

I than tried 'deep clean', twice, still nothing printed on the pages (With brand new sealed printhead and cartridges)

 

I did a hard reset - following a video on youtube (hold down cancel button, then press & hold 'on', then press cancel buttons five times - made some noises, still nothing being printed)

 

Ran 'reset' option via printer LCD, still nothing

 

I took out the printhead and inks, and did a nozzle clean on the printhead (ink seems to travel through printhead fine as alot of ink came when soaking printhead in water) reinserted clean and dried printhead and inserted inks - still nothing.

 

Ran 'auto align' to see if it is something mechanical - 'auto align' error display on LCD - just says 'refer to manual - :('

 

ran manual align - operation didnt come up with any errors, but still nothing printed on the paper, still blank.

 

uninstalled, cleaned registry (ccleaner) and reinstalled program (win 10 x64) - still nothing being printed although communicating via lan and wifi fine.

 

Restarted 'printer spooling' in 'services.msc', restarted, stopped and started. Still nothing being printed.

 

Tried to run a photocopy, still nothing printed.

 

Ran 'clean' and 'deep clean' again with intervals as to not overheat the printhead - still nothing, all inks are now emptied (2 XL sets)

 

Cleaned 'waste ink' sponges seated on the right in the rubber gaskets - still nothing.

 

I AM BEWILDERED!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

 

Any suggestions Canon?

 

Thanks!

4 REPLIES 4

mkimmyb
Apprentice
I am now having the same problem with my Canon MX715. Any luck on solving this problem?

As much as I wanted to repair the unit (As im pretty frugal and would be a shame to throw it away for such a minor thing)

 

I just gave up - i had tried everything that could potentially resolve it but ended up losing more money as I was spending several hours trying to get it to work. 

 

I ended up buying a new Canon MX725 for £79.99 on amazon, i think around $130-150. and sold the new printhead I had bought for half the purchase price.

 

So all in all, if you can't get it working after an hour or two, i highly recommended just ditching it and not waste your time - buy a new unit and smash the old f***er up !

 

Sometimes you gotta pick your battles, a non working printer is one of those losing battles.

 

 

I am almost 100% sure that Canon programs their printers to stop working properly and most probably it is not related to how many times you use it, but more how long you've had it. It occurs so often that the printer prints blank pages, and the service desk did not mention it and there is no solution. Thanks anyway

 

jsserver
Apprentice
Same problem with pixma MG 5250, Canon just says, should goto service departement but no parts are made for this printer. Error also gone after buying expensive head and new ink. Blank pages is the result. Must be indead the tears that count. 3 basic electronic parts are behind the printhead that problably burn through. So not nice from Canon because al tje nrw printers use a newer printhead. 80 Euros plus ink cist gone just like that!
Announcements
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
10/14/2022: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!