cancel
Showing results for 
Search instead for 
Did you mean: 

Canon MG 3520 printer freeze

Presrod
Apprentice
I have a mac osx operating system. When I plug in my Canon MG 3520, the only light that comes on is the 4x6 photo paper. When I press the power button, it'll turn on, but when I hold it down to turn off it won't turn off. So pretty much my printer freezes and doesnt respond to me even resetting it...if I hold down the stop button nothing flashes or anything. The printer was working fine last use.
9 REPLIES 9

pkain
Apprentice

No freeze just won.t print-you people are useless

won't print offline-you people are useless

what is metro start screen?

Try this- I found this suggestion on another site. I had exact same issue, tried so many things. This worked for me. Take a piece of aluminum foil, wide enough to fit under ink cartridge. I folded a piece 3 times to make it thicker. With power off, slide it from the front, underneath the black cartridge. (My ink carriage was all the way to the right so I just slid the foil under the one cartridge).'After you get it under there, turn the printer on. Mine started up and I pulled out the foil Amazing. 

Follow up- I think the whole problem has to do with the cartridges. I cleaned printer heads 2x after getting printer restarted. Possibly should replace the cartridges- they are just so expensive.

With printer on, hold down stop button until alarm flashes twice, release button and printer will go into clean function.

Presrod
Apprentice
Um ok?

BillS
Mentor

Hi presrod,

 

It seems that the printer is going into an error state, even if the alarm light does not come on.  Pressing and holding the Stop button for 5-7 seconds will dismiss many errors.  I also recommend removing and reseating the ink cartridges.

 

This didn't answer your question or issue? Please call or email us at one of the methods on the Contact Us page for further assistance.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

lulaesq
Apprentice

I see that your issue was a year ago (almost to the day), but replying anyway in the event it helps someone else.

You aren't supposed to do this but nothing else was working...My printer was completely frozen and none of the advice was helping (I don't even understand the foil one?). Either way, I physically unplugged my printer from power. While off, I opened the lid to get to the cartridges and I removed the cartridge I had just replaced the day before (just as an added measure) and reinserted it. I plugged the printer back in after about a minute and VOILA. Typically, forcing it off by unplugging these machines and giving it a forced restart does the trick. If not even that works for you, you definitely need to take it somewhere (or toss it if not under warranty - sometimes it's more expensive to fix, though it's good to get a quote).

 

Hope this helps someone! 😃

i too am having this issue. how do you get the cartridges out if the printer is frozen? I cannot reach them even with the little door open. They are over too far.

smetlucskynet
Apprentice

 I have the same problem with my MG3550. This works for me: disconnect the power line. Plug the power line in while holding the RESET button (RED triangle, also called STOP button)). Release the RESET button. The ALARM starts blinking. Push the "ON" button.

 

Hope this works for you too.

 

Announcements

07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500