Showing results for 
Show  only  | Search instead for 
Did you mean: 

ZoomBrowser EX isn't working on Win10. Doesn't see the camera when connected via USB. Any ideas?

Not applicable

I have a PowerShot Pro90 IS from 2002.  It's 21 years old, fully functional, and still taking excellent images.  Thanks Canon!  Providing great products for decades.

Unfortunately, the software that came with the camera, ZoomBrowser EX (V., works great on our old XP based computer.  That's right,,,I have an XP laptop up and running and this old software runs just fine on it.

I'd like to get an app (or a fix) that allows me to transfer images to my Windows 10 system directly from the camera.

Currently, I have to remove the data card and read it with my USB card reader accessory.  👎

I prefer NOT to take my card in and out of the camera every few shots for inspecting images.  Something about data connections and dust makes me nervous.  Moving images through a USB cable is a better (safer?) way to go.

I see that Canon has another app called ImageBrowser EX and I'm wondering if that software is compatible with Windows 10.

If so, how can I obtain a copy of ImageBrowser EX, and if it's not Win10 compatible, what are my options for transferring images from my camera via USB cable?

Thanks for any suggestions offered. 😀

Columbine flower - unprocessedColumbine flower - unprocessedColumbine flower - unprocessed JPEG



Not applicable

Have you tried connecting the camera to the laptop using a USB cable and using Windows File Explorer to download the picture files to the computer?

Not applicable

Yep,  tried that.  The Windows 10 File Exploder doesn't see the camera's storage media for some reason.  I suspect that the camera's firmware isn't Windows 10 compatible.  See previous replies for details on my troubleshooting.  The Windows 10 computer seems to be working correctly for other USB devices.

Downloading images and processing them on the XP laptop works fine, it's just the Windows 10 computer that has trouble.

Based on the symptoms, I'm thinking that the camera's firmware needs to be updated to be Win10 compliant.  I'm hoping there's a firmware update available from Canon.  If not, I'm probably stuck moving the storage media in and out of the camera.

Thanks for your reply and have a great day!  😀


You don't need ANY software to transfer directly from camera to computer. Just connecting then via USB cable should mount the camera in Windows File Explorer so you can drag & drop.

Does it?

Not applicable

Unfortunately, my computer doesn't recognize the data storage card, so it doesn't show up in Windows Exploder.

Every other USB device I plug into this computer (flash drives, thumb drives, etc.) works as expected.  Plus, when I plug my camera into the older XP laptop, XP recognizes the data storage media and the software works well for transferring and processing images.  The only issue there is,,, Windows XP.  Ugh!  If that laptop fails for any reason, I'm stuck moving the data card into and out of the camera all the time.

When I plug the USB cable into the computer (camera in PC Connection mode), Windows does provide the "new device connected" sound, but that's it's only response.  There's no other indication that the computer has recognized a "new device" or any other storage media.  No other storage devices are indicated in Windows Exploder. 

When I remove the USB cable, I get the Windows "device disconnected" sound, so I know the USB port is working properly.  I'm guessing that the sound is generated whenever a power connection is made and it doesn't mean that any data is being exchanged between the device and the computer.

I don't know enough about the camera's internal workings to say for sure, but there might be some firmware in the camera that aids in connecting to a computer.  If so, maybe a firmware update for the camera might be a solution.  Hopefully, some of the technical staff at Canon will know about what can be done to resolve this issue.

I really like this camera, so I'm hoping to keep it in operation for years to come, but transferring images via USB is a "must" have these days.  The newer models have Bluetooth or WiFi, so things have really improved over the decades.

I'm hoping that this is a software incompatibility issue with Win10 because that would probably be the easiest fix.  But, based on the symptoms, it could easily be a camera firmware issue.  Hopefully, the experts at Canon will be able to tell me if the firmware can be updated to be Win10 compliant.

Thanks for your reply and have a great day!  😃

Not applicable

Some on here have solved this issue by buying the genuine Canon data cable, which solved the connectivity issue with Windows 10/11. Part number of the cable should be listed in your manual.

This appears to be the Canon part for the USB cable for your camera: Canon IFC-200U USB Interface Cable. 

Not applicable

That's a good idea, but I'm using the original Canon data cable that came with the camera.

Everything I'm doing works fine on the old XP laptop, it's just the Win10 computer that's having trouble.

I'm really hoping Canon can provide this camera with a firmware update.  If not, then I don't see a solution for USB connectivity.

Thanks again for your reply and have a great day!  😀

Not applicable

Have you tried all your USB ports on your computer? You may want to try another USB cable anyway. Windows 10 seems to be more finicky with cameras and the USB cable.

Not applicable

Good idea...I'll give it a try.  I've had USB ports go bad in the past, so it's worth trying.

No change in the problem, but it did give me another idea about why the computer is recognizing the camera as a connected device, but not able to exchange data.

After connecting the camera, I get the dialog boxes that say "Setting up the PowerShot Pro 90 IS" (plus the sound) and another message saying "Installation is complete".  Apparently, the computer is able to determine the name of the device, so the firmware must be working correctly. 

So I checked the Device Manager to make sure the computer was seeing the camera and it IS listed.  After looking at "Properties" of the camera in the Device Manager app, it now appears that the computer doesn't have the correct "driver" for the camera, so that's probably where the problem lies.  I searched for an updated driver, but the computer didn't find one.  It's not shown in Windows Exploder probably because the correct driver isn't installed.

Now it's just a matter of finding a good Windows 10 compatible driver for the camera.  Woo-hoo!  👍  That seems do-able and likely to resolve the problem.

Hopefully, Canon can provide an updated driver, which seems like something that's likely to be available.  I can search the net for an appropriate driver, but I'd prefer to get it from Canon if possible.

Thanks for your ideas 5DIV, we may have just solved this problem.  It's definitely worth investigating.  🌞


Not applicable

See this post: 

He had a very similar problem, and the USB cable was the issue. I know yours works in older Windows versions, but Windows 10 seems to need a higher grade cable for camera connections. Worth a try.

Enter for a chance to win