Showing results for 
Show  only  | Search instead for 
Did you mean: 

Photos from EOS M200 won’t show up on Canon Camera Connect app


I took a handful of photos the other day on my EOS M200. They’re visible on my camera but for some reason are not showing up when I try to import images using my Canon Camera Connect app. I’ve never had this issue before. 

I tried uninstalling and reinstalling the app and reconnecting my camera to the app, as suggested from another user. Still no luck. Any other ideas? Thanks!



Thanks for joining the conversation, ChelseaW!

So that the Community can help you better, we need to know exactly which operating system is running on your mobile device (i.e. Android or iOS, and which version thereof). That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

I’m using iOS 17.3.1 on an iPhone 12 Pro

I just tested my M200 w/iOS 17.4. Works fine.

I know this doesn't solve your problem, but it does indicate that it is not a basic camera/software problem.

Sounds like the camera is connecting okay. Did you perhaps download the images previously? Maybe there's a flag that will prevent downloading a second time.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

That’s the strange thing is it’s connecting Bluetooth and WiFi just fine. I tried taking new photos just now and those showed up to import. I went into the camera and was able to manually select each photo for import but for some reason, the canon connect app wouldn’t import them on their own. Thanks for checking on your camera!