cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mac OS X 10.8 can't install Solutions Software

stuartworley
Apprentice

I can't get the Solutions CD to install/update the Canon software on my Macbook Pro. 

 

Running 10.8.3

 

I have DPP 3.11 installed. 

 

Also tried downloading updaters from Canon web, but these don't work either. 

 

 

Turned off 10.8 Gatekeeper security. Still no joy. 

 

What gives?

 

 

1 ACCEPTED SOLUTION

stuartworley
Apprentice

Well, I solved it myself. I saw a similar post somewhere about logging in as a different user and installing from that account. Amazingly, that worked. 

 

I installed a couple of the apps from the CD from my wife's account and everything went well. I went back to my account to install the rest of the CD and still no dice!

 

So, back to my wife's account to complete the install. I haven't tried installing any updates from the Canon support site. 

 

So, Canon Support, I hope this give you some hint of what is going on with your installer. I can't believe that I am the only person who has had this issue. 

 

Stuart

View solution in original post

30 REPLIES 30

Tim
Authority

Hello Stuartworley,

In your response you did not indicate which model camera you are using.  This is helpful for us to troubleshoot the exact cause of the issue.  So we do need this to provide precise information.  That being said, it may not be necessary to update Digital Photo Professional to 3.13.0 depending on the camera you use.  That update provided support for images taken with the EOS Rebel T5i, EOS-1D C and a few new lenses.  No program changes were implemented, other than support for those models. 

The first thing we suggest is to verify the administrator account privileges and reset if necessary.  We also suggest verifying disk permissions on this system, this may take a while.  As a last resort, if you still have issues, we would recommend uninstalling the software in it's entirety and install fresh from the disk.

If you need to get in contact with Canon right away, please use our Service and Support portal to contact us via email or phone support.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

The issue has nothing to do with my camera model.

I have tried repairing permissions, no luck.

I have removed previous versions of Canon software, no luck.

Any other suggestions?

Hi Stuartworley,
The camera model tells us which CD-ROM you're likely to have, but isn't critical.

 

For Mac x ver 10.8, you should be using "Digital Photo Professional 3.13.0".  What happened when you attempted to install it?

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Canon 6D

 

The CD that came with it is Ver. 27.1 with DPP 3.12 on it. The installer on it runs, then quits without doing anything. 

 

I tried downloading DPP 3.13 updater. I run its installer, and it quits after saying that it has extracted files, and does nothing. 

 

I've tried installing the other apps and they all do the same thing. 

 

I've removed my earlier copy of DPP and tried installing new ones. No luck. 

 

Is there a "hidden" preferences file that I should delete? 

I just got my 5d Mark lll today and am frustrated by the software.  When trying to install on my Mac laptop running OS 10.8.3 I'm told repeatedly that I need administrator privileges.  I am the admin and can install anything else without any hassle.

 

I've reset disc permissions, checked for permissions on the files and folders involved in the installation, rebooted,  looked for old fragments of Canon software on the machine.  Nothing works.  Any ideas?

 

Thanks.

Hello Movpic,

Since you have checked the permissions but made no mention of repairing them, you may want to try this.  Other users on this forum are also reporting that making a new account with administrator privileges and then reinstall the software.  Currently we are unaware of any issues with our software and Mac 10.8.3.  So, try making a new account and then re-install all the software. 

If this is a time sensitive-matter, additional support options are available through our Support Site.  Please use this to Contact Us.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Creating a new user is a cumbersome workaround. I often need to switch seamlessly between programs and don't have time to log out and in again. There is a bug in the installation process. Canon needs to fix this.

When you install for the 'new' user you get the option to install for all users, once it's installed, login as your normal user and DPP will be available to you, I then deleted the user I made to install it and DPP is now available in my normal user profile - you don't have to switch users to use it.

I'm having the same problem. I'm using OS 10.7.5, and had no joy at all installing from the supplied disk (v111.0). I downloaded the software from the Canon site, and managed to install the Image Browser. However, I cannot install the Camera Window software, which is telling me that I need to be an administrator. 

 

I've tried every admin account on the Mac. I've created a new one. I've turned off admin privaliages, restarted, turned them back on, restarted, and still no joy. 

 

Guess what; I'm a little frustrated....

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.