Showing results for 
Show  only  | Search instead for 
Did you mean: 

Eos utility doesn't work using windows 10 64 bits computer


So basically doesn't work, when I connect the camera right away show in the camera screen the logo of a computer, and when I go to the PC, doesn't show me anything of the Eos utility to work but I can see the card in my PC. Thing is I need to remoted. I downgrade Eos utility, upgrade. Deleted update for windows and update again, update bios. No luck. Settings in the camera of wifi and Bluetooth are off. Using windows 10 64 bits

I used utility 3 directly and didn't work. Many ports and cable and still the same, it's not the camera cause I can used in another computer, but my personal no. I'm using canon r5 with the Propper utility from the website

Even I formatted the card and restore camera, no luck




To have a better understanding of your issue, please let everyone know the operating system on your computer.

If this is a time-sensitive matter, please check out your other support options here.



Let’s begin with telling us which camera you have.  What brand of computer to you have and which Operating System are you running?

Make sure that you have Bluetooth and Wi-Fi functions disabled.  Use the supplied cable.  Do not use any USB port adapters.

The motherboard firmware in some computer brands need for you to manually start the EOS Utility 3 the first time you use it.  Think of it as a jump start.

If the OS detects your camera after turn it on and asks you what action should it take, then select “Take No Action.”

"The right mouse button is your friend."

I have tried always utility 3. Asus is the brand of the tower. Used 3 diferents cables usb c to a and c to c. None work. Also update the form of the camera. 3 days ago was working fine. Canon r5.

Not applicable

It might be worth trying all the USB ports on the computer. Sometimes a different port works.

I've tried every single port

Not applicable

Try launching the EOS Utility 3.exe Windows File Explorer and see if that helps.

Screenshot 2023-08-12 203755.jpg

Not applicable

Can you post a screenshot of the logo of a computer that you see when connecting the camera? There are 2 different screens that appear when connecting using the EOS Utility. I assume you don't see the screen that shows only the camera back.

The first screen shows a computer and a laptop and is displayed by EOS Utility.exe. The second screen shows the back of a camera and is displayed by EOS Utility 3.exe. Are you seeing only the first or is the second screen displayed after a delay?


The behavior being described is not something I've seen before.  I don't recall any of my cameras displaying a computer logo when connected to a PC, W10 , W11 or MAC.  They mount as a mass storage device (Windows Explorer) or external drive (MAC).  I've been using card readers for years now.  I am familiar with the connection's menu on the camera, but haven't had a need to use it in a long while.  


Connect the USB-C cable to your camera.  Turn it on.  Now plug the other side into a USB/USB-C port on the computer.  Does the camera mount and appear in Windows Explorer?

If you don't hear a detection sound and it doesn't appear, open Device Manager.  Do you have any entries there with a yellow triangle or red exclamation ! marks?

You're not connecting to any hubs or adapters, correct? 

How many disks do you have installed?  Does windows have a drive letter available to assign to the camera?

What about System Restore?  You said everything worked 3 days ago.  Try restoring to a point in time when things worked.  

Once the camera mounts successfully in Windows Explorer, the EOS Utility should also work.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It


 I downgrade Eos utility, upgrade. Deleted update for windows and update again, update bios. No luck.

None of that sounds good, to me.  Are you running an Asus off-the-shelf computer or a desktop built from an Asus motherboard?

"The right mouse button is your friend."