cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility no longer working

Ploppy54
Contributor

Hello, The beta worked spot on but since the update it no longer works. OBS doesn't recognise it as a source to select, ive tried turning off EOS ultity ive tried unistalling it altogether. I have a 2000D and connected via a USB and the computer picks up the camera and i can transfer my pictures but i use it for live streaming EOS webcam software doesn't start i don't have a splash screen. cap2.PNGcap3.PNGsource.PNG

please can advise

i have a

Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz

NVIDIA GeForce GTX 1050 Ti
16 GB Ram
Windows 10
9 REPLIES 9

Waddizzle
Legend

Check to make sure the EOS Utility Launcher Service is not running, too.  You never would have been able to run the Beta version if the service was running.  When you upgrade to the release version the service could have been re-enabled.

--------------------------------------------------------
"The right mouse button is your friend."

Ploppy54
Contributor

Nope i can't find a launcher service on my system 

Services are not apps. A bad comparison would be to compare it to a device driver. 

it would look like a camera icon in the System Tray near the clock,  typically on the lower right.  Also, the Task Manager would list the EOS service, if it were running.

--------------------------------------------------------
"The right mouse button is your friend."

nope 

Ploppy54_0-1659886023018.png

 

The icon for the EOS Service looks like a camera, nearly identical to the icon used for Digital Photo Professional.  That green smudge of an icon could be it.  Right click on it.

--------------------------------------------------------
"The right mouse button is your friend."

shadowsports
Elite

Greetings,

Since only limited information was provided, we don't know much about your environment or system, actual feature and build of windows 10 or what "update" windows or the WebCam Utility you are referring to, we are only guessing.  AVG might also be blocking something required for the utility to operate. 

The release notes for the WebCam Utility states you should uninstall the the beta before installing v1.1.

At this point, maybe System Restore would be a good idea.

~Rick
Bay Area - CA
~R5C (1.0.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra
~ImageClass MF644Cdw ~Pixel6 
~6D2 (v1.1.1) retiring

Ploppy54
Contributor

Okay so i tried the system restore and that didn't work, however i found a download of the beta version and its appeared on my streaming service options... However when i tried to select it the camera display flickered a few times and streamlabs (the streaming service) crashed and wouldn't allow me to select it.

Ploppy54_0-1659909225496.png

 

oddlycaptured
Apprentice

Thanks to @shadowsports for saying something about AVG.


I had this same issue where the Webcam Utility just stopped working last week. (8/5) and was finding nothing. I uninstalled and reinstalled several times. I just checked AVG and turned off my "webcam security" and the EOS webcam splash screen returned. So IF you are running AVG, I think the new AVG update is not allowing the Webcam Utility to start up. Unsure if this is something Canon just needs to submit to AVG or patch themselves.

TL;DR - You can just turn off the "Webcam security" function on AVG while you're in need of using the EOS webcam utility. Hope that helps!

Ploppy54
Contributor

Further to this I found a download link to the beta version. This showed up in strealabs but crashed when I tried to select it. I restarted the pc and this time with the camera turned off it had activate selecting this and then turning the camera on worked a charm. Now whenever I use streamlabs it picks up my camera straight away although it is the beta software that it's using, I just hope I'm not forced to install the update. 

Announcements
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available forRF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!