Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility issue - Live view freeze




I have been using the live view EOS function on my 5D mark iii for years now and I have not had an issue until today. I use this in order to stream and record videos, however after around 15 minutes the live view freezes and crashes. After firing it back up I can no longer access the live view however I still have access to the shutter, ISO and files ect .... I am not sure what seems to be the issue.


Things I have tried so far; 


Reinstall everything

Use EOS 2 and not 3

Taking out the SD card

Running the 5D in photo mode

Running the 5D in video mode


I am currenly out of ideas now. I understand there is an issie with Windows 10 and EOS right now.. might that have something to do with it? I am currently running windows 10.


Any help would be great!




Problem solved Part 2


This morning my WiFi connection did the same thing transfer 2 pictures and freeze I was thinking what I did differently from yesterday when everything was going so smoothly I did transfer over 600 pictures thru WiFi with no problem. IMG.jpg

And Eὕρηκα,  I found the problem!
after updating my Router I never turn ON  my VPN but in the morningn after restart  the VPN loads automatically.
So now I know the VPN causes the problems with WiFi connection and camera.


Some results for transfer 10 RAW images 653Mb total

1) WiFi to the computer on Lan (connected to router with cable) 3min 18sec  (19.8sec per image)
2) WiFi to directly to laptop not using network or router 3min 51sec  (23.1sec per image)
3) WiFI using network setting camera WiFi to router -  laptop WiFi to router 8min 24sec  (50.4sec per image) I have to find why it so long and tweak that.

4) Cable USB 3.0 17.75sec  (1.7sec per image)

5) Cable USB 2.0 27.0sec   (2.7sec per image)

The test with USB3.1 connection went completely wrong Robot Sad
I was described myself as a computer guru and I was ripped off by local computer store ??? Technician ???  This card is not USB 3.1  only USB 3.0  with USB Type C 2.4A Quick Charge green USB on the back whatever this means this port does not recognize anything just charge.
There are not USB 3.1 cards with Internal USB3.0 header so far I search.

Ok, I will slap myselff in the  head and call silly    Smiley Embarassed



Same problem here with my 5D Mark IV. 

@tcom wrote:
the same issue here 5D mark IV it freeze after transfer 5-15 pictures
dose not matter destination
dose not matter what memory SD odr fast CF
dose not matter battery, cable or grip
install-reinstall update all the same freeze after 5-15 images transfer


Camera was already sent to Canon for repairs, electrical system has been switched but did not resolve the issue.


Any news on this one?



Thanks and cu


Is there anyway to make EOS 3 run in 64 bit format? On the task manager it is showing up as 32 bit. Might this have something to do with it ?


After using live view I find the camera computer will crash. It may crash after a few minutes or a few hours. Only way I have found to avoid this is to cycle power to the camera (NOT on/off switch), actually unplug it if using AC adapter or remove battery. 

Other issue with live view is that camera will overheat and stop working if in live view too long. 


Hope that helps. 


Not sure if this relate to your issue, but I had problems with live view - Worked fine on my smal Helix tablet and would not load properly on my T30s with a NVIDIA card - dissabled the NVIDIA card and works like a sharm