Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R cannot connect via WiFi to EOS Utility (Win 11)


Hello, I have an EOS RP (mirrorless low-end model) and I would like to do remote shooting over the WiFi connection, using Capture One Pro, which I already know works with wired capture. I have a problem seemingly identical to the one here: Solved: Re: EOS R EOS Utility WiFi bug - Canon Community. I followed the instructions that atis said he was told to follow, however they did not fix my problem.

EOS RP firmware version: 1.6.0 (interestingly the firmware version only shows up in the menu when not in video mode...Canon???)

EOS Utility version: (the problem also happened on which was initially what I installed).

I tried using the Pairing over Wi-Fi/LAN shown below:


but the pairing window does not show any devices available on the network.


Since the plugged-in mode of the application worked, I wanted to try getting the two devices paired while connected over USB, but it is not possible to select the WiFi pairing mode while the camera is plugged in. Instead what happens is the app loads a menu. The download images slot is greyed out, probably because I have no SD card in the camera.


I tried connecting to the camera via 2 different methods: A) private WiFi network hosted by the camera, which did not work, as the WiFi network was not even discovered by my desktop's WiFi adapter, which is 802.11ac and ax (that is, WiFi 6E) capable, and B) via my router's WiFi network, which also did not work. My PC is connected to the router via Ethernet. I tried two methods of connecting to the router's network, both of which seem to have connected to the router successfully: A) selecting SSID and entering password; and B) using WPS-button mode; however, I was still unable to get the EOS Utility to recognize the camera. I allowed the camera to configure its own IP address in both methods. I've tried the connection multiple times via each method.

As for the camera's configuration:

  1. Wi-Fi: Enabled
  2. Password: Required
  3. Auto-send images to computer: Disabled
  4. Bluetooth function: Remote
  5. Nickname: EOSRP
  6. Wi-Fi function selected for connection process: Remote control (EOS Utility)

As for the direct WiFi connection, when the camera creates its own network, my computer sees a Hidden Network, which I believe could be it, but it will not connect if I type in the password given by the camera.


My computer will also not connect if I define a new network using the given SSID and password and check the box that tells it to connect even if the network is not visible.


It is unclear whether I should be using WPA3 or WPA2 or WEP. This detail is not mentioned in the official Canon documentation.





In re: to @shadowsports's reply in the thread I mention in the original post:

I answered most of those questions in the new post. As for the firewall, I believe the installer/EOS utility asked for permission to communicate through the firewall, which I granted.



The firewall allows it through only on Private networks. My ethernet network is specified as Private, so this should not be a problem.


I have also tried running EOS Utility in Windows 7 compatibility mode. This did not work.


Wow.  Very well written and detailed post.   👍

Is there any 3rd party AV software installed besides Windows Security?

I see you are using the default camera name EOSRP-688_Canon0A (also good)

Private network type - perfectly acceptable for a Home Network

Note, you cannot do anything wirelessly when the camera is connected or tethered via USB.  This doesn't work.  

For security I'd use WPA/WPA2 AES

Is your router or AP dual or tri-band?  Is it using the same SSID name for both or all broadcasts?  Give the broadcasts unique names for testing.

Let me get my cameras out to test.  I've never tried wireless tethering and always use my mobile and CC App for remote control.  

Let's see if someone else responds who can also test in their environment for additional perspective.


Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Update. Confirmed camera only supports 2.4Ghz WPA/WPA2 AES



Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It


I connect to cameras using Wi-Fi while my PC is using Ethernet.  It is the best way to do it, instead of using the hotspot inside of the camera, when a local WAP is available.

Make sure your home router is not using an approved MAC address list.  If so, you will need to temporarily disable it so that the camera can connect to your home router.  Once connected, you should be able to detect the MAC address and add it to the approved MAC address list.

"The right mouse button is your friend."

Hi, thanks for the reply. I am using ethernet. I know the router settings intimately and have not restricted device access by MAC address. Considered firewall as issue but firewall is only on outbound traffic. Other devices have no problem with network discovery (Canon printer for example).


Another great point.  👍  Access Control if enable will not allow new devices to connect until added.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Another booby trap would be connecting as a Guest, which would only give access to the Internet but not the local network.

"The right mouse button is your friend."

The Guest network is on a separate SSID. I tested this. Connected to the protected network by selecting its SSID in the camera menu. WPS button also connects to the protected SSID instead of the guest network.

The camera connects to the network. It just does not get discovered by the software. Would I be right in assuming that, were the camera unable to connect to the network successfully, it would display an error message on the camera? It does not do that. Only sits there and waits for the EOS Utility app to sniff it out.