Showing results for 
Show  only  | Search instead for 
Did you mean: 

Downloader for


Hello, is working without issue with my Canon Powershot ELPH 360 HS. Where my problem is, is in the "Downloader for ( It used to work on my computer but now says "Failed to connect to the server". I'm sure this message is because I'm not signed in. When I click "User Authentication" I get "An unexpected error occured". I've uninstalled, reinstalled the software, tried to run as administrator and in compatibilty mode (even though it is compatible with Windows 10). I tried Canon support but they are no help and have exhausted my Google search with no solution. I'm hoping you guys have any idea what I could do. Please and thank you!


Product Expert
Product Expert

Hi there,


That does sound a little odd especially based on the troubleshootign you've done. At that point I would guess it is a problem on the other end but it doesn't seem like a lot of other people are experiencing this. Since it is an authentication issue, I wonder if resetting your password would help.

I keep getting into a similar state where the downloader needs to get reauthenticated--very inconvenient.