Showing results for 
Show  only  | Search instead for 
Did you mean: 

DPP 4.11.02 crashing randomly on Windows 7 x64bit


I had an older version, not sure exactly which one, indeed was prior than 4.10.20 since I remember when it came out I found it very unstable on editing specific CR2 files.

So I turned back to the old version which never crashed and I kept using it until few days ago, when I installed the update 4.11.02, hopefully it would be stable but the trouble started.
Initially it opens correctly but then is randomly crashing on trying to change to edit view on JPG, CR2 and even checking the info to see which lens I used to take a specific shot.

The instability is present either running the app from my standrd user and , always logged in with the same standard user, running by using execute as administrator.

I already tried the uninstall, reboot reinstall method, as well as deleting the canon folder in c:\ProgramData without luck.
Please if anyone else is still usign windows 7 and have a working release of DPP let me know which version it is.


Thanks in advance.






I am sorry to hear that this issue persists.  We recommend trying a different computer to see if the issue has to do with the computer or the software.  

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

On a different computer, running Windows 10 professional 64bit I do not have issues with version 4.10.50 and only EOS Lens registration tools is having problem with 4.11.02 which could be solved by using the same tools coming with 4.10.50 version.


On this W7 computer I tried several versions of DPP, 4.11.02 4.10.50 4.10.20 and 4.7.21.


4.10.20 is somehow stable except when it comes to the automatic light setting, just touching the control and before having time to release the mouse over the new position, from standard to high for example, I got again AppCrash with most of the pictures.


The oldest version, 4.7.21 did not show any app crash. For the moment I went back to that but I am not sure how old is it, neither it does seem to be able to use lens correcton; I think I got that release from a CD coming with my former compact camera, a Powershot G3 X



On a third different computer, I have the same random crash. It always happens when I try to edit over a CR2 raw file. Working on older images that I sho on JPG format only does not give me any issue.

The Systems where it crashes:
Custom built AMD Phenom II X4 @3.1GHz (quad core) 12GB RAM Win7 pro x64 Italian, GPU Nvidia 1050TI

Custom built AMD Athlon64 4000+ @2.40GHz (single core) 4GB RAM Win7 ultimate 32bit Italian, GPU AMD Radeon R5 200 ; this one indeed I can't be sure if issues are related to the poor hardware since it works usually only with the OS and windows media player.


The System where it works:

Asus U32U netbook, AMD E2-400 @1.6Ghz (dual core) 8GB Ram, Win10 professional English, Integrated graphic Radeon HD6320


All the three systems are up to date with windows update.


The most probable case to me seem that something on the newer version broke compatibility with Windows 7, especially considering that  the first system worked as a charm for many months using an older version until I tried to use 4.11 first and then 4.10.

Both were crashing, after that uninstall and re-installing 4.7.21 no more crashes


You are not running Intel. Asus users seem to always have issues. You have seen the specs. Your AMD is the problem. Period.
"The right mouse button is your friend."

Thank you for your explanation, I have just few further notes


You are not running Intel

 - Correct

Asus users seem to always have issues

 - This does not matter to my case, indeed the only computer where I am able to use version 4.11.02 without crash issues is an Asus U32U where I have Windows 10 (running on AMD too).


Your AMD is the problem:
- Quite generic explanation and indeed nothing of what you wrote explained why this is an issue only on a couple of windows 7 computer and not on the Windows 10 one.

Indeed my AMD, Intel compatible according to the maker, is the problem only when I try to use a version newer than 4.7.21;

In fact with this old version everything works fine and always did on my system and as always I will keep doing until I will be using a camera not requiring CR3.


Definetely windows 7 is a almost dead systems and perhaps investigating a possible issue with newer DPP release it is worthless, Indeed it is still the second most used operative system of whole internet connected computers according to recent surveys, just following Windows 10.

Among all these AMD CPU could be very rare and of no interest, but how can you be sure that this is really the issue?


In case you can forward to someone who wishes and is capable to investigate the reason of this crashing do not hesitate to contact me for further technical details, i.e. dumps, filemon.


You skipped one line.

“You have seen the specs.”

"The right mouse button is your friend."