Showing results for 
Show  only  | Search instead for 
Did you mean: 

DDP4.18 not loading in Windows 11


I've been using DPP4 (not sure which version) on a laptop (Dell i7 w/ 32 GB RAM) running Windows 10 for the last 4 years. Has worked wonderfully and I love how easy it is for an amateur to edit RAW images to get better looking shots.

Last week I migrated to a new computer (Dell i9 w/ 32 GB RAM + 8 GB video RAM). Installed DPP4.18.

First time I tried opening it, it seemed to work, but a screen popped up saying something about a neural network tool. I clicked on okay, it downloaded and installed. I tried running DPP4. The loading screen came up, and it stayed that way for over half an hour. I tried it several times, no joy. I uninstalled DPP4 and reinstalled it. Still no joy.

I did get it to finish loading one time - again the screen popped up about the neural network thing, this time I clicked on No/Cancel - and the software froze. Tried uninstalling and reinstalling, and it seems stuck at the loading screen - this time I left the computer for over an hour, still on the loading screen.

Anyone have any suggestions?



Delete DPP.

Download the free version of CCleaner and do a registry check.

Reinstall DPP and do not select the neural network tool option and see if that works.


John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

I did try this. It will load now - but it takes over an hour to do so. So until that gets fixed, I won't be using it. Looking into whether Adobe Photoshop Express or Lightroom Classic might be a suitable replacement.

Either of those two programs would be suitable replacements. LrC is a subscription based program. Photoshop Elements is a one-tine purchase perpetual license. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic



I have some additional suggestions if you are interested.  I'm not running the neural network tool.  I'm running DPP 4.18.0 on a modestly appointed laptop.  Core i7 (10th gen), 16GB.  Its an older CPU, and runs W11.  DPP runs pretty well on it.  Of course where I see a slow down is when I am performing batch processing, or importing 500-800 photos.  I usually just walk away for a short while.  DPP is not my primary editor, and the system its installed on is not my primary workstation.

John provided excellent advice.  Uninstall DPP and run CC Cleaner.  In addition, I may have tried System Restore.

I wonder if the issue you are having is related to video drivers?  I'm sure the card with it's dedicated 8GB is plenty of for DPP and the neural network too, but occasionally Dell does some quirky things with its drivers.  You might visit the Dell Support portal and enter your service tag to see if newer drivers are available.  Newer chipset drivers could help as well.

Try running DXDIAG and see if any problems are reported.  You can also review the System Event Viewer for errors which might explain the application failing to start or run timely.  



You can also check the integrity of the operating system's core files by running sfc /scannow from a elevated command prompt.  Does it report any integrity violations and if so, was it able to repair them?


After unistalling DPP, the neural network tool and running CC Cleaner, I might also review Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Canon_Inc_IC in REGEDIT and delete the DPP4 and DPP4 Shared folders under the key. 


In addition, I'd delete any Canon folders from Program Files, Program Files (x86) and Common Files.  By default, the App Data folder under your user profile is set to hidden, but you can expose it and remove the Canon folders from it as well.


These are some of the things I might do or check to see if I could get DPP working again in your environment.  😃

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It