Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS 6D / Remote ( tethered ) shooting / EOS utility / Mac Ventura? HELP!!!


So I am confused...   I own an EOS 6D.  I have a M1 mac running Ventura, 13.2.1.     I AM able to physically cable my 6D to my mac to tether do remote shooting.  I run EOS Utility 2 , version 2.13.41 ( intel)  ....  It functions just like it does on my T3.    Question........ I can find no EOS software that is "M1 compatable".    OR anyway to update this old software.     I have downloaded the "EU-Installset-M3.16.10.8.dmg". AND EU-Installset-M3.15.20.4.dmg".   I run it, it mounts a drive, but when I run the installer, it just says "Extracting files".  ... then nothing.     Anybody have any ideas?     Is this the EOS software I should be using for a 6D on an M1 mac?    help.. maybe a link???


NEW!!!!!!!!!!!!!!    IT is fixed, sorta.     Installed SW on wife's M1, transfered that SW to my M1.   Now I have EOS Utility 3.16.10.  YEAH!!!!    thanks all for your help.    ( now just have to figure out what I did to break my MAC!! )



Canon Software for macOS 13 (Ventura) - Canon Community

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic


If you are just downloading images, you don't need any Canon Software. Image Capture (standard on the Mac) does just fine.

Trying to physically cable my 6D to my mac to tether to do remote shooting.    Have a window that I can set speed, apature, ISO, etc. Just like the EOS utility did on my T3. 

The easiest place to find the most current versions of all of the software that is licensed for use in the United States is within your My Canon Account at 
You may have to manually change the OS to macOS 12 if there haven't been any updates to the software since the newest OS was released (as is this case). The most current version I see as of right now is EOS Utility 3.15.20 for macOS

Stephen.  Thank you so much for the reply.     Here is what I do.  STEP#1 ... I downloaded the EOS utility from your link.  STEP#2 ..Double click on this "EU-Installset-M3.15.20.4.dmg" file.  STEP#3.. it opens a window, where the left half says Canon and shows 6-7 photos.  The right half of this window shows a DVD with an arrow and the words "eum3.15.20-installer".    STEP#4 I double click on this this installer....   It opens a window that says "Extracting Files.....  "  then it goes away.  I can find nothing it does....   It does not load SW or modify anything.    What is it suppose to do?     NOTE...  I removed all the canon SW from my hard drive, then ran this installer again..  Does the same ( nothing other than "extracting"....    thoughts?   

Give our team a call - 800-OK-CANON (800-652-2666). They'll walk you through it! 😉

click here to view the press release