cancel
Showing results for 
Search instead for 
Did you mean: 

Canon Digital Photo Professional wouldn't start after the latest win10 update

Digimark
Apprentice

Hi Everyone,

I always used DPP 4.11 without problem, but few days ago windows10 did some updates by itself and as result,  now any time i try to start DPP, i get an error message "Runtime error" : " this application has requested the runtime to terminate it in an unusual way- microsoft visual C++ runtime library".
I tryied to uninstall DPP and reinstall it few times,but I could'nt find a solution to make it start.
If someone had my same experience and maybe found the solution yet, please let me know.

 

Thank you very much in advance to everyone, that would pay attention to my problem and that will help to solve my issue.

 

Best Regards

Mark Di Giovanni

32 REPLIES 32

Waddizzle
Legend

Contact Canon Support.

--------------------------------------------------------
"The right mouse button is your friend."

GavM
Apprentice

Experiencing the same issue.

 

Did you get a response from support?

I registered just to add a me-too here.

 

I've tried every trick I know from 30+ years in IT and none have worked.

Hello!


Welcome to the Canon Forums!

 

So that the Community can help you better, we will need to know exactly what Canon equipment you're using, along with any error messages you're seeing. It might also be helpful to know which version of Windows 10 you're using as well. 

Any other details you'd like to give will only help the Community better understand your issue!


The Canon Community isn't intended for immediate assistance. If you're in the United States, and this is an urgent support need, please click HERE to enter your product information to discover your support options. 

If you're outside of the USA, please click HERE to find support options in your country.

Thanks and have a great day!

I'm having the same problem as well when starting the DPP4, I get "Runtime Error! This application has requested runtime to terminate in an unusual way." I've tried reinstalling DPP4, booting in Safe Mode, update display drivers, deleting all the old Microsoft Visual C++ that didn't have "Repair" option and did the "Repair" for the ones that allowed me the repair option. I still get the same error.

moranjr
Contributor

Crashes after upgrade 😞

GPanepinto
Apprentice

Hello,

 

I have the same issue since yesterday.

It seems related to the upgrade of c++ Runtime Libray from 2017 to 2015-2019 version.
I spent 4 hours of my time to check how i could resolve the problem but without results. I tried to unistall all C++ Versions and Re-installed all, I tried to use the old 2017 version, I tried also tu Unistall and Install some different versions of DPP but notthing to do... I verify the same issue on Photo Style Editor. I tried to install last Windows Update but this was another useless step.

I hope that the last 5 or 6 months of works arent't lost.

I contacted Italian Support Team this morning. Hoping to a new relase that fix the issue......

(Sorry my bad English).

mraj
Contributor

Hi, Forum,

Newbie here, hope you're all having a great day! Please include me, having the same issue, upon starting up my DPP4  crashes with "Runtime Error! This application has requested runtime to terminate it in an unusual way, Please contact application's support team for more information" since 11/9, I believe after a recent Windows 10 update - I'm using Windows 10 pro w/ 32 GB RAM, i7-6700 desktop computer with pro 10-bit color calibrated monitor. 

 

I contacted Canon tech support and here's what I got, "Canon is currently aware of the run time error with DPP 4 and Windows 10. The issue occurred when Microsoft updated their .Net Framework and Canon is working with Microsoft to come up with a resolution to the issue however at this time I do not have an ETA of when this issue will be resolved".

 

Meanwhile I've tried all known tricks listed by several members in here, no dice. Good news, Canon is aware of this issue and working on it, bad news is ETA unknown - I hope they won't have to do a major overhaul which would involve lots of testing. I'm in a frustrating wait mode like you all. My biggest frustration at this time is, the same DPP4 v4.11.0 works just fine in two of my laptops running Windows 10 pro with the same latest OS updates, Canon go figure. I have all my working files and workflow setup in my desktop, I'm in hold mode since 11/9 😞

 

Please let me know if any of you found a solution for this issue, thank you. 

 

Good day, mraj

I uninstalled DPP4 then removed all "Canon" folders in Program Data, Program Files, Program Files (64) , rebooted and then reinstalled. It seems to work except for lens profiles.
Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM