Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Camera Connect

I am trying to pair my Google Pixel 2 to my Canon Rebel T7i via bluetooth. When I tried to connect my phone to the WiFi on the camera, I had to use the NFC method and when I did, my phone would only stay connected to the camera for a couple of seconds.

So now I'm trying to connect using the bluetooth, and my Canon will show up on my phone to connect to. However when I go to click the name and it shows that the pairing is in process and then it just stops pairing after a couple seconds. I tried clearing the cache of the Canon Camera Connect app on my phone and that did nothing.

Also on my camera when I go to the Bluetooth function after clicking on Wireless Communication Settings, the pairing button is faded out and I can't click on it. At first I thought that meant my camera was connecting to my phone, but then after some research I realized that you're supposed to be able to click on that button and then the pairing process begins. Please help, I'm not sure where to go from here.



Is your camera in USB or wireless mode?  

"The right mouse button is your friend."

How do I check that? Also when I went to change the display settings, it brought up this balance test thing, where I have to tilt the camera and line it up with this red line until it turns green. How do I fix this? Everytime I click out of the menu it goes to it.

Nevermind, I just turned my camera off and it stopped doing that!