Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R6 Control Ring Mount adapter EF-EOS not working



my control is not working whatsoever. The Camera being used is an R6. I’ve tried cleaning the contact points with a soft towel, I’ve tried enabling the shutter to close without a lens setting (this may work once) and then I get the error 01 message. I’ve tried multiple lenses and each does not work on the adapter but will work on a separate camera body (6D). I have also made sure I’ve cleared any custom settings that may be effecting the control ring negatively. 

Not sure what else to try between the camera and the adaptor. at this point do I take it to a technician, call canon, or buy a new ring? 



Well things do break. You have to make the choice do you mess with repair or buy a new one. It sure sounds like it is something wrong with the adapter but I am not a technician. 

BTW, stop cleaning the contacts as you have seen this almost never to never works or even helps. Plus you can do more damage that help. You did do a full reset? I mean a full reset. You have a good fully charged Canon brand battery. Man that about it since you confirmed the lenses do work on other cameras.

EOS 1DX and 1D Mk IV and less lenses then before!

I did try a full reset for both custom and camera settings. Still nothing 



Perform a full camera reset as Ernie recommends.  This includes both Main and Custom functions.  

Following this, remove the camera's battery, then press and hold the shutter for 10 sec.  Re-insert the battery, and remount one of your adapted EF lenses.  Without making any customizations, try taking a series of photos.  You should not receive any Err01 messages.  If you do, the adapter is faulty. 

If you do not experience any errors, make one, single customization to the Control Ring operation and retest.  This should help you determine the source of the problem.

Any service or inspection should be performed by Canon or an authorized service center.    

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It


What EF mount lenses are you using?   What brand(s)?

Do you have any native RF mount lenses that you could test?

What brand of RF-EF mount adapter are you using?

"The right mouse button is your friend."