Showing results for 
Show  only  | Search instead for 
Did you mean: 

Vixia HF R52 not downloading onto Mac, nor Canon image Gateway


I own a new HF R52 and own a Mac Mini with OS X Yosemite 10.10.1.   I can't download to my hard drive or external hard drive.  As an end around I tried to upload to Canon Image Gallery through my Canon account but it won't download when I click the download button.  I recorded in AVCHD, so I thought that was the problem, so I tried a test video in mp4 and that didnt download as well.


I can usually figure things out, but after hours of trying to get my computer to recognize my Vixia, I need your help. 


Thanks for your help in advance




In Applications, Canon Utilities, is there a program called CameraWindow ?

That pops open whenever I plug in my Vixia HF M50 and it is set to display MP4 movies. MP4 is seen and shows a thumbnail. It does not open when the camera is set to display AVCHD movies.

iMovie will import both types. 

A normal USB cable is used. 


Just out of curiosity when you connect with the USB cable does the camera's internal drive show up as an external drive in Finder?


Since it is recognized in Finder, are you able to select clips and then copy and paste to the desired location?

Same isssue.  But my answer to the question "does the camera show up in FINDER?"  is No.  Please advise

So, to make sure I undserstand, nothing (including the camcorder) shows in finder when you connect the camcorder via the USB cable?  I'm guessing the video is stored on the internal memory of the camcorder.  If yes, have you tried copying the clips to an SD card and using a card reader to copy the files to the computer?

My cannon Vixia HFR500 won't download to my macbook pro. The macbook picks up the cannon via Photos, but not on finder. The message reads that the files are uneadable or corrupted. I have tried (suggested on Google) pluging the camera into the computer and then immediately turning off Photo as soon as it turns off, but it done' work. Photo insists on registering the camera onto photo. There is no way to stop Photo from automatically turning on when I connect the camera to the Macbook (via USB). There is no way to uninstall Photo. The camera will not register in Image Capture. The camera USED to download to my computer fine. Did this happen when I upgraded to Yosemite? I have spent hours trying to google and find out what this problem is. The computer sees the videos and show little pictures of each one as stills. It allows me to choose which ones I want to upload - but when I try to uplaod - then I get the message. The camera plays back directly to my wide screen via appropriate cables.The camera plays it's own videos on its little screen fine. I am running Yosemite. Any ideas?  


P.S. this is not really a help desk from Cannon when they just send you to a chat room and don't allow you to connect with them is it... Shame on them.

@VideoGeek wrote:

Just out of curiosity when you connect with the USB cable does the camera's internal drive show up as an external drive in Finder?

Not in the finder. It only shows up on the left column of the import page "Photo" App. Is it possible this happened when iphoto changed to Photo?




Thanks for posting on our forum!


This community is designed for your fellow Canon owners to help each other out with any problems they may encounter. If this is a time-sensitive matter, our US-based technical support team is standing by, ready to help 24/7 via Email at or by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 10 PM ET (7 AM to 7 PM PT).